summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGreg Schlomoff <gregschlom@google.com>2022-03-16 18:47:08 -0700
committerGreg Schlomoff <gregschlom@google.com>2022-03-22 11:34:53 -0700
commit2d0697141e3e99121a78226536e5cc8d40d724b3 (patch)
treed0d177f3fbc97ab5d4681918c441e5b2fb34d281 /CMakeLists.txt
parent34ec41a6b60abdf42bdd298fdefe15f66dfc2c32 (diff)
downloadvulkan-cereal-2d0697141e3e99121a78226536e5cc8d40d724b3.tar.gz
Adding a way to add properties to cmake tests.
This will be used by downstream gfxsatream users to skip some tests from running on CI Test: ran build script Change-Id: Ic1da644ff0240f1b34d99baaa3879ff91b2f12f0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2b081b5..45766eca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,4 @@
+cmake_policy(SET CMP0048 NEW)
project(gfx-streaming-kit)
cmake_minimum_required(VERSION 3.11)
@@ -57,6 +58,12 @@ if (MSVC)
add_compile_definitions(_CRT_NONSTDC_NO_DEPRECATE)
endif()
+# Macro to easily set the TEST_INCLUDE_FILES properties to point to `test_properties.cmake`
+# This macro should be called at the end of any CMakeLists.txt file that defines test targets.
+macro("set_test_include_files")
+set_property(DIRECTORY APPEND PROPERTY TEST_INCLUDE_FILES ${CMAKE_SOURCE_DIR}/test_properties.cmake)
+endmacro()
+
# Uncomment for ASAN support
# set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-omit-frame-pointer -fsanitize=address")
# set (CMAKE_LINKER_FLAGS "${CMAKE_LINKER_FLAGS} -fno-omit-frame-pointer -fsanitize=address")