summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoshua Duong <joshuaduong@google.com>2022-05-16 21:28:41 -0700
committerJoshua Duong <joshuaduong@google.com>2022-06-06 19:26:30 -0700
commitdc302d0652f7c3797246e1be170826025958e4b1 (patch)
tree2a4a017fbcf1a7fc96ab3215630336ed8ae4f5b6 /CMakeLists.txt
parent3369fb606f94c01bd76a07686073f302aca5dffc (diff)
downloadvulkan-cereal-dc302d0652f7c3797246e1be170826025958e4b1.tar.gz
Move host-common headers into host-common/include.
This will allow aemu to inject it's own implementation of these APIs. Bug: 224794781 Test: compiles Change-Id: Id13abfb76a8ea52f26ec5272d63eea1a8e3cbe3e
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 532e3828..d858497a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,13 @@ cmake_minimum_required(VERSION 3.18)
option(BUILD_ASAN_WIN32 "Build with ASAN on Windows platform" OFF)
+option(BUILD_STANDALONE "Build with standalone implementations of base/host-common libraries" ON)
+if (BUILD_STANDALONE)
+ # These libraries may be changed in non-standalone builds to inject another implementation of
+ # these APIs.
+ set(GFXSTREAM_HOST_COMMON_LIB gfxstream-host-common)
+endif()
+
if (WIN32)
add_definitions("-DUNICODE -D_UNICODE -DNOMINMAX -DEMUGL_BUILD -DVK_USE_PLATFORM_WIN32_KHR -DBUILDING_EMUGL_COMMON_SHARED")