summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKaiyi Li <kaiyili@google.com>2021-08-21 15:12:02 -0700
committerKaiyi Li <kaiyili@google.com>2021-08-26 10:57:37 -0700
commitfab51001f25345f4b94d4980a641d132aa22e9bc (patch)
treede1239719ef8f7475335dc36fbe7b73028184749 /CMakeLists.txt
parent3420acb2ddce73135c84266e9c946cab202cad63 (diff)
downloadvulkan-cereal-fab51001f25345f4b94d4980a641d132aa22e9bc.tar.gz
Use a separate class to manage virtio-gpu fence signaling
Use a separate class with queues to record the virtio-gpu fences and their payloads, and call the callback of fences once all previous tasks on the timeline is marked complted. Test: run the emulator, VirtioGputTimelines_unittests Change-Id: I57a2ce5cee1781a2a3b511a43e96b347208571cc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd266921..3b7dd491 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,6 @@ option(BUILD_GOOGLETEST "Download and build the googletest library" ON)
if (WIN32)
add_definitions("-DUNICODE -D_UNICODE -DNOMINMAX -DEMUGL_BUILD -DVK_USE_PLATFORM_WIN32_KHR -DBUILDING_EMUGL_COMMON_SHARED")
- add_definitions(/MP)
endif()
if(UNIX AND NOT APPLE)