summaryrefslogtreecommitdiff
path: root/host-common/CMakeLists.txt
diff options
context:
space:
mode:
authorLingfeng Yang <lfy@google.com>2020-10-29 07:42:55 -0700
committerLingfeng Yang <lfy@google.com>2020-10-29 07:42:55 -0700
commit187b9d36a6d18c4dfb46a7a079354d1e0a20213c (patch)
treea1e472ace864b5fc6a8e0122ddc748a5ce0ef083 /host-common/CMakeLists.txt
parent87321ae2198996892b6de4dd2e816f821d5e7b48 (diff)
downloadvulkan-cereal-187b9d36a6d18c4dfb46a7a079354d1e0a20213c.tar.gz
Build goldfish sync/dma device interfaces
Bug: 171711491 Change-Id: Ifc2d1131c60ee225d62bbac9d26986057c9a34e4
Diffstat (limited to 'host-common/CMakeLists.txt')
-rw-r--r--host-common/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/host-common/CMakeLists.txt b/host-common/CMakeLists.txt
index b1c0dd77..fc9f6a7c 100644
--- a/host-common/CMakeLists.txt
+++ b/host-common/CMakeLists.txt
@@ -2,6 +2,11 @@ add_library(
gfxstream-host-common
crash_reporter.cpp
vm_operations.cpp
- feature_control.cpp)
+ feature_control.cpp
+ dma_device.cpp
+ sync_device.cpp)
target_include_directories(
- gfxstream-host-common PUBLIC ../)
+ gfxstream-host-common
+ PRIVATE
+ ${GFXSTREAM_REPO_ROOT}
+ ${GFXSTREAM_REPO_ROOT}/stream-servers)