summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMd Mansoor Ahmed <mansoor@codeaurora.org>2018-11-20 11:06:32 +0530
committerMd Mansoor Ahmed <mansoor@codeaurora.org>2018-11-20 11:06:32 +0530
commit2382aaad1a62a1d8b95a32cf5edd04bce745e1bd (patch)
tree76ea96bc0e9fd3f21e0d4e235ba328ba071677e6 /Makefile.am
parente95846085a4fc81abe98a9d53aa6cb7d3cd13c78 (diff)
downloadmsm-extra-2382aaad1a62a1d8b95a32cf5edd04bce745e1bd.tar.gz
Asoc: Enable audio-dlkm compilation for sdmsteppe target
Enable compilation for sdmsteppe target and also fix compilation errors. Change-Id: I18a13764415ae955843706943e338bb575c11853 Signed-off-by: Md Mansoor Ahmed <mansoor@codeaurora.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bd60e537..4a9f96ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,6 +23,9 @@ endif
ifeq ($(TARGET_SUPPORT),qcs40x)
KBUILD_OPTIONS += CONFIG_ARCH_QCS405=y
endif
+ifeq ($(TARGET_SUPPORT), sdmsteppe))
+KBUILD_OPTIONS += CONFIG_ARCH_SM6150=y
+endif
obj-m := ipc/
obj-m += dsp/
@@ -30,7 +33,7 @@ obj-m += dsp/codecs/
obj-m += soc/
obj-m += asoc/
obj-m += asoc/codecs/
-ifeq ($(TARGET_SUPPORT), $(filter $(TARGET_SUPPORT), sdm670 qcs605))
+ifeq ($(TARGET_SUPPORT), $(filter $(TARGET_SUPPORT), sdm670 qcs605 sdmsteppe))
obj-m += asoc/codecs/wcd934x/
endif
ifeq ($(TARGET_SUPPORT), $(filter $(TARGET_SUPPORT), apq8053 sdm670 qcs605))
@@ -44,6 +47,10 @@ obj-m += asoc/codecs/bolero/
obj-m += asoc/codecs/csra66x0/
obj-m += asoc/codecs/ep92/
endif
+ifeq ($(TARGET_SUPPORT), sdmsteppe))
+obj-m += asoc/codecs/bolero/
+obj-m += asoc/codecs/wcd937x/
+endif
all:
$(shell rm -fr $(shell pwd)/soc/core.h)