summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLinux Build Service Account <lnxbuild@localhost>2020-10-20 23:13:16 -0700
committerGerrit - the friendly Code Review server <code-review@localhost>2020-10-20 23:13:16 -0700
commit73a3066e99368ef4b8c85a50855508ace74963fc (patch)
treef8596204f1fc14a5298c42eb2dcfd057a7185333 /Makefile.am
parent2922723c6f75b0ce32b392f1547ce2e354676e7b (diff)
parenta9e1270b31d85975ada90c647c463e180d264bf8 (diff)
downloadmsm-extra-73a3066e99368ef4b8c85a50855508ace74963fc.tar.gz
Merge "ASoC: sdxlemur: Add support for new target compilation" into audio-kernel-5-4.lnx.1.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bfb69d01..62f3b6f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,6 +17,11 @@ endif
ifeq ($(TARGET_SUPPORT), sdmsteppe)
KBUILD_OPTIONS += CONFIG_ARCH_SM6150=y
endif
+ifeq ($(TARGET_SUPPORT), sdxlemur))
+KBUILD_OPTIONS += CONFIG_ARCH_SDXLEMUR=y
+endif
+
+subdir-ccflags-y += -I$(AUDIO_ROOT)/include/uapi/
subdir-ccflags-y += -I$(AUDIO_ROOT)/include/uapi/
@@ -25,7 +30,7 @@ obj-m += dsp/
obj-m += soc/
obj-m += asoc/
obj-m += asoc/codecs/
-ifeq ($(TARGET_SUPPORT), $(filter $(TARGET_SUPPORT), sdmsteppe))
+ifeq ($(TARGET_SUPPORT), $(filter $(TARGET_SUPPORT), sdmsteppe sdxlemur))
obj-m += asoc/codecs/wcd934x/
endif
ifeq ($(TARGET_SUPPORT), $(filter $(TARGET_SUPPORT), qcs40x))