summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorcristy <urban-warrior@git.imagemagick.org>2013-04-12 19:21:07 +0000
committercristy <urban-warrior@git.imagemagick.org>2013-04-12 19:21:07 +0000
commit9e27ba8dc94b7b697f6d40c368aec9c4db034d4c (patch)
tree31de2f14656d88495a4bf77e5d0942c3dc19a9ef /Makefile.am
parent7473adfa3286fddb0c6a550026997c4f809f9142 (diff)
downloadImageMagick-9e27ba8dc94b7b697f6d40c368aec9c4db034d4c.tar.gz
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am60
1 files changed, 1 insertions, 59 deletions
diff --git a/Makefile.am b/Makefile.am
index 1376c0a02..7eb3b38d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,10 +40,8 @@ CLEANFILES = \
$(UTILITIES_CLEANFILES) \
$(TESTS_CLEANFILES)
-utilities_bin_PROGRAMS = \
+bin_PROGRAMS = \
$(UTILITIES_PGMS)
-utilities_bindir = $(LIB_BIN_DIR_PATH)
-
# Binary scripts
bin_SCRIPTS = \
@@ -193,62 +191,6 @@ uninstall-local: $(MAGICK_UNINSTALL_LOCAL_TARGETS) \
$(HTML_UNINSTALL_DATA_TARGETS) \
$(UTILITIES_UNINSTALL_LOCAL_TARGETS)
-install-exec-hook:
- @list='$(utilities_bin_PROGRAMS)'; test -n "$(utilities_bindir)" || list=; \
- if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(bindir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(bindir)" || exit 1; \
- fi; \
- for p in $$list; do echo "$$p $$p"; done | \
- sed 's/^utilities\///g' | sed 's/$(EXEEXT)$$//' | \
- while read p p1; do if test -f $$p || test -f $$p1; \
- then echo "$$p"; echo "$$p"; else :; fi; \
- done | \
- sed -e 'p;s,.*/,,;n;h' -e 's|.*|.|' \
- -e 'p;x;s,.*/,,;s/$(EXEEXT)$$//;$(transform);s/$$/$(EXEEXT)/' | \
- sed 'N;N;N;s,\n, ,g' | \
- $(AWK) 'BEGIN { files["."] = ""; dirs["."] = 1 } \
- { d=$$3; if (dirs[d] != 1) { print "d", d; dirs[d] = 1 } \
- if ($$2 == $$4) files[d] = files[d] " " $$1; \
- else { print "f", $$3 "/" $$4, $$1; } } \
- END { for (d in files) print "f", d, files[d] }' | \
- while read type dir files; do \
- if test "$$dir" = .; then dir=; else dir=/$$dir; fi; \
- test -z "$$files" || { \
- echo "$(LN_S) $(DESTDIR)$(utilities_bindir)/$$dir ./$$dir"; \
- (cd $(DESTDIR)/$(bindir) && \
- rm -f ./$$dir && \
- $(LN_S) $(DESTDIR)/$(utilities_bindir)/$$dir ./$$dir) || exit $$?; \
- } \
- ; done;
-
-uninstall-hook:
- @list='$(utilities_bin_PROGRAMS)'; test -n "$(utilities_bindir)" || list=; \
- for p in $$list; do echo "$$p $$p"; done | \
- sed 's/^utilities\///g' | sed 's/$(EXEEXT)$$//' | \
- while read p p1; do if test -f $$p || test -f $$p1; \
- then echo "$$p"; echo "$$p"; else :; fi; \
- done | \
- sed -e 'p;s,.*/,,;n;h' -e 's|.*|.|' \
- -e 'p;x;s,.*/,,;s/$(EXEEXT)$$//;$(transform);s/$$/$(EXEEXT)/' | \
- sed 'N;N;N;s,\n, ,g' | \
- $(AWK) 'BEGIN { files["."] = ""; dirs["."] = 1 } \
- { d=$$3; if (dirs[d] != 1) { print "d", d; dirs[d] = 1 } \
- if ($$2 == $$4) files[d] = files[d] " " $$1; \
- else { print "f", $$3 "/" $$4, $$1; } } \
- END { for (d in files) print "f", d, files[d] }' | \
- while read type dir files; do \
- if test "$$dir" = .; then dir=; else dir=/$$dir; fi; \
- test -z "$$files" || { \
- echo " link program $$files to '$(DESTDIR)$(bindir)$$dir'"; \
- for file in $$files ; do \
- (cd $(DESTDIR)/$(bindir) && \
- rm -f ./$$dir) || exit $$?; \
- done; \
- } \
- ; done;
- rm -r -f $(LIB_BIN_DIR_PATH)
-
clean-local: $(PERLMAGICK_CLEAN_LOCAL_TARGETS)
distclean-local: $(PERLMAGICK_DISTCLEAN_LOCAL_TARGETS)