summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCristy <urban-warrior@imagemagick.org>2018-02-23 17:47:45 -0500
committerCristy <urban-warrior@imagemagick.org>2018-02-23 17:47:45 -0500
commit2dad3d6dca6d7412550cf8f188d5281d1a4b7354 (patch)
treeb2d059cb0d5268c4a1e22932febbc8e31259e9f0 /Makefile.am
parentc3df32ec5a53bda80a732594dce620bbfdc6ab69 (diff)
downloadImageMagick-2dad3d6dca6d7412550cf8f188d5281d1a4b7354.tar.gz
...
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a19a2ffb5..461dc658e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -369,11 +369,12 @@ DIST_ARCHIVE_RPM= \
.PHONY: rpm
rpm: dist
+ rm -rf $(RPMDIR)
$(MKDIR_P) $(RPMDIR)
$(MKDIR_P) $(RPMDIR)/BUILD
$(MKDIR_P) $(RPMDIR)/RPMS
$(RPM) --define="_sourcedir `pwd`" --define="_rpmdir `pwd`/$(RPMDIR)/RPMS" --define="_builddir `pwd`/$(RPMDIR)/BUILD" --nodeps -bb ImageMagick.spec
- rm -rf $(RPMDIR)
+ rm -rf rpmbuild
@echo ==============================================================
@echo $(DIST_ARCHIVE_RPM) is ready for distribution.
@echo ==============================================================