summaryrefslogtreecommitdiff
path: root/filters/Makefile.am
diff options
context:
space:
mode:
authorcristy <urban-warrior@git.imagemagick.org>2009-10-28 02:21:20 +0000
committercristy <urban-warrior@git.imagemagick.org>2009-10-28 02:21:20 +0000
commit23e50e26007146c5b96da479b047e7bb9fda18e1 (patch)
tree45dc6e1bd496890c6c1bf147d45bc5ed5e235eb8 /filters/Makefile.am
parent79f189952032391bb2623c5efe0202152d9f0986 (diff)
downloadImageMagick-23e50e26007146c5b96da479b047e7bb9fda18e1.tar.gz
Diffstat (limited to 'filters/Makefile.am')
-rw-r--r--filters/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/filters/Makefile.am b/filters/Makefile.am
index 3067f0527..c4ab76b4c 100644
--- a/filters/Makefile.am
+++ b/filters/Makefile.am
@@ -12,19 +12,19 @@
# See the License for the specific language governing permissions and
# limitations under the License.
#
-# Copyright (C) 2003 - 2008 GraphicsMagick Group
-#
# Makefile for building ImageMagick filter modules.
# Where filter modules get installed
filtersdir = $(FILTER_PATH)
MAGICK_FILTER_SRCS = \
- filters/analyze.c
+ filters/analyze.c \
+ filters/boost.c
if WITH_MODULES
filters_LTLIBRARIES = \
- filters/analyze.la
+ filters/analyze.la \
+ filters/boost.la
else
filters_LTLIBRARIES =
endif # WITH_MODULES
@@ -35,3 +35,8 @@ filters_analyze_la_CPPFLAGS = $(MODULE_EXTRA_CPPFLAGS)
filters_analyze_la_LDFLAGS = $(MODULECOMMONFLAGS)
filters_analyze_la_LIBADD = $(MAGICKCORE_LIBS) $(MATH_LIBS)
+# boost filter module
+filters_boost_la_SOURCES = filters/boost.c
+filters_boost_la_CPPFLAGS = $(MODULE_EXTRA_CPPFLAGS)
+filters_boost_la_LDFLAGS = $(MODULECOMMONFLAGS)
+filters_boost_la_LIBADD = $(MAGICKCORE_LIBS) $(MATH_LIBS)