summaryrefslogtreecommitdiff
path: root/filters/Makefile.am
diff options
context:
space:
mode:
authorcristy <urban-warrior@git.imagemagick.org>2014-05-19 00:45:15 +0000
committercristy <urban-warrior@git.imagemagick.org>2014-05-19 00:45:15 +0000
commit30841e6deb8306e8b6103121209a9f7fd76161f5 (patch)
tree68af61f0dec7c60336a837b303e4bf8fa62cb47b /filters/Makefile.am
parent326182d587fc1b1a8c934dafbf412d05615a540a (diff)
downloadImageMagick-30841e6deb8306e8b6103121209a9f7fd76161f5.tar.gz
Diffstat (limited to 'filters/Makefile.am')
-rw-r--r--filters/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/filters/Makefile.am b/filters/Makefile.am
index 7a8a68df2..d122eb19c 100644
--- a/filters/Makefile.am
+++ b/filters/Makefile.am
@@ -17,6 +17,8 @@
# Where filter modules get installed
filtersdir = $(FILTER_PATH)
+MAGICK_FILTER_CPPFLAGS = $(AM_CPPFLAGS)
+
MAGICKCORE_FILTER_SRCS = \
filters/analyze.c
@@ -26,9 +28,10 @@ filters_LTLIBRARIES = \
else
filters_LTLIBRARIES =
endif # WITH_MODULES
+filters_CPPFLAGS = $(MAGICK_FILTER_CPPFLAGS)
# analyze filter module
filters_analyze_la_SOURCES = filters/analyze.c
-filters_analyze_la_CPPFLAGS = $(MODULE_EXTRA_CPPFLAGS)
+filters_analyze_la_CPPFLAGS = $(MAGICK_FILTER_CPPFLAGS)
filters_analyze_la_LDFLAGS = $(MODULECOMMONFLAGS)
filters_analyze_la_LIBADD = $(MAGICKCORE_LIBS) $(MATH_LIBS)