summaryrefslogtreecommitdiff
path: root/filters/Makefile.am
diff options
context:
space:
mode:
authorcristy <urban-warrior@git.imagemagick.org>2009-09-05 21:47:34 +0000
committercristy <urban-warrior@git.imagemagick.org>2009-09-05 21:47:34 +0000
commit3ed852eea50f9d4cd633efb8c2b054b8e33c2530 (patch)
tree02825a47137626849f8f6d9c486ea1587186f5ca /filters/Makefile.am
downloadImageMagick-3ed852eea50f9d4cd633efb8c2b054b8e33c2530.tar.gz
Diffstat (limited to 'filters/Makefile.am')
-rw-r--r--filters/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/filters/Makefile.am b/filters/Makefile.am
new file mode 100644
index 000000000..072bf95b8
--- /dev/null
+++ b/filters/Makefile.am
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 ImageMagick Studio LLC, a non-profit organization
+# dedicated to making software imaging solutions freely available.
+#
+# You may not use this file except in compliance with the License. You may
+# obtain a copy of the License at
+#
+# http://www.imagemagick.org/script/license.php
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# Copyright (C) 2003 - 2008 GraphicsMagick Group
+#
+# Makefile for building ImageMagick filter modules.
+
+# Where filter modules get installed
+filtersdir = $(FILTER_PATH)
+
+MAGICK_FILTER_SRCS = \
+ filters/analyze.c
+
+if WITH_MODULES
+filters_LTLIBRARIES = \
+ filters/analyze.la
+else
+filters_LTLIBRARIES =
+endif # WITH_MODULES
+
+# analyze filter module
+filters_analyze_la_SOURCES = filters/analyze.c
+filters_analyze_la_CPPFLAGS = $(MODULE_EXTRA_CPPFLAGS)
+filters_analyze_la_LDFLAGS = $(MODULECOMMONFLAGS)
+filters_analyze_la_LIBADD = $(MAGICKCORE_LIBS)
+