aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrank Barchard <fbarchard@google.com>2022-06-17 19:12:38 -0700
committerXNNPACK Team <xnnpack-github-robot@google.com>2022-06-17 19:13:42 -0700
commit4aa243068e71f1064e8db37f6240e4c85f1f5314 (patch)
tree389c303e39d3581873930b89800199ab6b830608 /CMakeLists.txt
parent9468b61a8c2628c911263bee7872cf99e4377be9 (diff)
downloadXNNPACK-4aa243068e71f1064e8db37f6240e4c85f1f5314.tar.gz
Add pixel tile of 16 for f32-bilinear-chw
- fix template for P greater than 9 - tests if p8 is infact best PiperOrigin-RevId: 455739616
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ff1403232..bd9fa0cba 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1697,6 +1697,7 @@ SET(ALL_NEON_MICROKERNEL_SRCS
src/f32-gemm/gen/8x8s4-minmax-neon.c
src/f32-ibilinear-chw/gen/neon-p4.c
src/f32-ibilinear-chw/gen/neon-p8.c
+ src/f32-ibilinear-chw/gen/neon-p16.c
src/f32-ibilinear/gen/neon-c4.c
src/f32-ibilinear/gen/neon-c8.c
src/f32-igemm/gen/1x8-minmax-neon-dup-ld64.c
@@ -2744,6 +2745,7 @@ SET(ALL_NEONFMA_MICROKERNEL_SRCS
src/f32-gemm/gen/8x8s4-minmax-neonfma.c
src/f32-ibilinear-chw/gen/neonfma-p4.c
src/f32-ibilinear-chw/gen/neonfma-p8.c
+ src/f32-ibilinear-chw/gen/neonfma-p16.c
src/f32-ibilinear/gen/neonfma-c4.c
src/f32-ibilinear/gen/neonfma-c8.c
src/f32-igemm/gen/1x8-minmax-neonfma-dup-ld64.c
@@ -3717,6 +3719,7 @@ SET(PROD_SSE_MICROKERNEL_SRCS
src/f32-gemm/gen/4x2c4-minmax-sse.c
src/f32-gemm/gen/4x8-minmax-sse-load1.c
src/f32-ibilinear-chw/gen/sse-p8.c
+ src/f32-ibilinear-chw/gen/sse-p16.c
src/f32-ibilinear/gen/sse-c8.c
src/f32-igemm/gen/1x8-minmax-sse-load1.c
src/f32-igemm/gen/4x2c4-minmax-sse.c