summaryrefslogtreecommitdiff
path: root/cras/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cras/Makefile.am')
-rw-r--r--cras/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/cras/Makefile.am b/cras/Makefile.am
index 6ecfbaec..6c89bdcb 100644
--- a/cras/Makefile.am
+++ b/cras/Makefile.am
@@ -5,3 +5,10 @@ AUTOMAKE_OPTIONS = foreign
SUBDIRS = src
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libcras.pc
+
+compile_commands.json:
+ which bear || (echo "Please install 'bear' first." && exit 1)
+ bear make check -j$(nproc)
+
+clean-local:
+ rm -f compile_commands.json