aboutsummaryrefslogtreecommitdiff
path: root/alsaconf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'alsaconf/Makefile.am')
-rw-r--r--alsaconf/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/alsaconf/Makefile.am b/alsaconf/Makefile.am
new file mode 100644
index 0000000..a11ecc5
--- /dev/null
+++ b/alsaconf/Makefile.am
@@ -0,0 +1,37 @@
+sbin_SCRIPTS = alsaconf
+man_MANS = alsaconf.8 alsaconf.fr.8
+EXTRA_DIST = $(man_MANS)
+SUBDIRS = po
+
+install-man8:
+ @for i in $(man_MANS); do \
+ ext=`echo $$i | sed -e 's/^.*\\.//'`; \
+ inst=`echo $$i | sed -e 's/\\.[^.]*$$//'`; \
+ case $$inst in \
+ *.[a-za-z]*)\
+ loc=`echo $$inst | sed -e 's/^.*\\.//'`; \
+ loc="/$$loc"; \
+ inst=`echo $$inst | sed -e 's/\\.[^.]*$$//'`;; \
+ *)\
+ loc="";; \
+ esac; \
+ $(mkinstalldirs) $(DESTDIR)$(mandir)$$loc/man$$ext; \
+ echo " $(INSTALL_DATA) $$i $(DESTDIR)$(mandir)$$loc/man$$ext/$$inst.$$ext"; \
+ $(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(mandir)$$loc/man$$ext/$$inst.$$ext; \
+ done
+
+uninstall-man8:
+ @for i in $(man_MANS); do \
+ ext=`echo $$i | sed -e 's/^.*\\.//'`; \
+ inst=`echo $$i | sed -e 's/\\.[^.]*$$//'`; \
+ case $$inst in \
+ *.[a-za-z]*)\
+ loc=`echo $$inst | sed -e 's/^.*\\.//'`; \
+ loc="/$$loc"; \
+ inst=`echo $$inst | sed -e 's/\\.[^.]*$$//'`;; \
+ *)\
+ loc="";; \
+ esac; \
+ echo " rm -f $(DESTDIR)$(mandir)$$loc/man$$ext/$$inst.$$ext"; \
+ rm -f $(DESTDIR)$(mandir)$$loc/man$$ext/$$inst.$$ext; \
+ done