aboutsummaryrefslogtreecommitdiff
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
index 2f09596..f384669 100644
--- a/avahi-core/Makefile.am
+++ b/avahi-core/Makefile.am
@@ -171,3 +171,13 @@ valgrind: avahi-test
gdb: avahi-test
libtool --mode=execute gdb ./avahi-test
+
+Android.mk: Makefile.am
+ androgenizer -:PROJECT avahi -:SHARED avahi-core -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libavahi_core_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(CFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(libavahi_core_la_CFLAGS) \
+ -:CPPFLAGS $(CPPFLAGS) $(AM_CPPFLAGS) \
+ -:LDFLAGS $(libavahi_core_la_LIBADD) $(libavahi_core_la_LDFLAGS) -llog \
+ > $@