aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoryonghong-song <yhs@fb.com>2019-09-24 20:08:31 -0700
committerGitHub <noreply@github.com>2019-09-24 20:08:31 -0700
commit903513e454c9847370f7e54797ff29f12e1de4d9 (patch)
tree6c7ff8b00714da91a5bf60a6971ea555c023a6f1 /CMakeLists.txt
parentc02e5eb13d154661af39a27f202ee64ad6be63a1 (diff)
downloadbcc-903513e454c9847370f7e54797ff29f12e1de4d9.tar.gz
cmakefile change to require c++14 (#2529)
The latest llvm trunk (llvm 10) built require c++14. Built with gcc and llvm 10 headers, the following error will show up: ... /home/yhs/work/llvm-project/llvm/build/install/include/llvm/Support/RWMutex.h: At global scope: /home/yhs/work/llvm-project/llvm/build/install/include/llvm/Support/RWMutex.h:101:8: error: ‘shared_t$ med_mutex’ in namespace ‘std’ does not name a type std::shared_timed_mutex impl; ... /home/yhs/work/llvm-project/llvm/build/install/include/llvm/Support/TrailingObjects.h:252:19: error: ‘is_final’ is not a member of ‘std’ static_assert(std::is_final<BaseTy>(), "BaseTy must be final."); ... std::shared_timed_mutex and std::is_final etc. are all c++14 features. Most compilers should already support c++14. Let us require it in Makefile now. Signed-off-by: Yonghong Song <yhs@fb.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61d9ac98..c2b72665 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,7 +86,7 @@ if (USINGISYSTEM AND GCC_VERSION VERSION_LESS 6.0)
endif()
set(CMAKE_CXX_STANDARD_REQUIRED ON)
-set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD 14)
endif(NOT PYTHON_ONLY AND ENABLE_CLANG_JIT)