summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastian Wilhelmi <wilhelmi@ira.uka.de>2000-04-28 12:24:53 +0000
committerSebastian Wilhelmi <wilhelmi@src.gnome.org>2000-04-28 12:24:53 +0000
commit1418fe3a6dd0c76bcdf644c87d956353bd5b940c (patch)
tree4956606935418bbc6c3e3c4cc0297897e17d1523 /Makefile.am
parentf0e9f522c21228f05afd15696d74e7f285e1838e (diff)
downloadglib-1418fe3a6dd0c76bcdf644c87d956353bd5b940c.tar.gz
New File implementing an asynchronous queue to be used for asynchronous
2000-04-28 Sebastian Wilhelmi <wilhelmi@ira.uka.de> * gasyncqueue.c: New File implementing an asynchronous queue to be used for asynchronous inter-thread communication. * gthreadpool.c: New File implementing a thread pool to be used for distributing work among several threads. * glib.h: Added the type and function declarations for these two types. * tests/threadpool-test.c: New File implementing a test for the thread pool. This also checks the asynchronous queue underlying the thread pool. * tests/Makefile.am: Changed accordingly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f970a3c7..95221d5ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,7 @@ lib_LTLIBRARIES = libglib.la
libglib_la_SOURCES = \
garray.c \
+ gasyncqueue.c \
gcache.c \
gcompletion.c \
gdataset.c \
@@ -58,6 +59,7 @@ libglib_la_SOURCES = \
gstrfuncs.c \
gstring.c \
gthread.c \
+ gthreadpool.c \
gtimer.c \
gtree.c \
gutils.c