summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeff Garzik <jgarzik@src.gnome.org>1998-11-12 04:28:52 +0000
committerJeff Garzik <jgarzik@src.gnome.org>1998-11-12 04:28:52 +0000
commit242cb51bfeb87c878e3895d5de2cbde290e25559 (patch)
treec9d1f795dd5e2eb013c2e25e63f176348a77c543 /Makefile.am
parent24273ca743bc88e8c2a64fead4f13b8367af0ddd (diff)
downloadglib-242cb51bfeb87c878e3895d5de2cbde290e25559.tar.gz
INCLUDES is the right way to add to CFLAGS, not DEFS. Also there are bugs
INCLUDES is the right way to add to CFLAGS, not DEFS. Also there are bugs with '+=' in makefiles. Got rid of DEFS line by moving G_LOG_DOMAIN setting into INCLUDES. Removed redundant -I from INCLUDES. This fixes an annoying bug where autoconf's DEFS, which includes the important -DHAVE_CONFIG_H, was lost. (due to += weirdness)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 75e448345..bf03bcc65 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,7 +12,7 @@ bin_SCRIPTS=glib-config
BUILT_SOURCES=glib-config
glib-config: glib-config.in
-DEFS += -DG_LOG_DOMAIN=g_log_domain_glib
+INCLUDES = -DG_LOG_DOMAIN=g_log_domain_glib
EXTRA_DIST = \
glib.m4 \
@@ -63,7 +63,6 @@ stamp-gc-h: config.status
libglib_la_LDFLAGS = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE)
-INCLUDES = -I$(top_srcdir)
noinst_PROGRAMS = testglib
testglib_LDADD = libglib.la