summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>1998-08-10 00:26:44 +0000
committerTim Janik <timj@src.gnome.org>1998-08-10 00:26:44 +0000
commit52f1266e0a713c0325cd78658fcd96a842bf5913 (patch)
tree5f7cfeb9557995f9756ad608e5a51b139d543d04 /Makefile.am
parentd94e25520b79e165860ed9346dc999d1256060d6 (diff)
downloadglib-52f1266e0a713c0325cd78658fcd96a842bf5913.tar.gz
minor hack to cause SUBDIRS (gmodule) to be build last. we do this by
Mon Aug 10 02:17:19 1998 Tim Janik <timj@gtk.org> * Makefile.am: minor hack to cause SUBDIRS (gmodule) to be build last. we do this by making all-recursive-am depend on all-am. Mon Aug 10 02:18:31 1998 Tim Janik <timj@gtk.org> * Makefile.am (lib_LTLIBRARIES): for now, skip the dependency on -lglib for libgmodule-1.1.la, libgplugin_a.la and libgplugin_b.la since this clashes with inter-library-dependencies for not installed libraries. glib-config takes care of this for the usuall case, but there needs to be a better way...
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5316cae0a..5835caa9c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,6 +12,9 @@ EXTRA_DIST = \
glib.m4 \
glib.spec
+# build . first, then SUBDIRS
+all-recursive-am: all-am
+
lib_LTLIBRARIES = libglib-1.1.la
libglib_1_1_la_SOURCES = \