summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJosh MacDonald <jmacd@icw.EECS.Berkeley.EDU>1998-06-12 09:38:32 +0000
committerManish Singh <yosh@src.gnome.org>1998-06-12 09:38:32 +0000
commitdf9a49ec3cbb19e58be929548cfba12452c55d83 (patch)
treedaae20dab8506a7890a24b2657c7217d1b769401 /Makefile.am
parentf62aace5b0706da62eef4be9052cb71608d97fef (diff)
downloadglib-df9a49ec3cbb19e58be929548cfba12452c55d83.tar.gz
[Changes from josh to sync with his glib stuff -Yosh]
Fri Jun 12 00:39:28 1998 Josh MacDonald <jmacd@icw.EECS.Berkeley.EDU> * glib.h: add new hash and equal functions g_int_*. complement g_direct_hash with g_direct_equal. * grel.c: new file, GRelations implement tuples of N-N mappings. A comment in glib.h briefly describes the interface. * ghash.c: new function, g_hash_table_size * glib.h: new typedefs, gsize, gssize, gtime. * garray.c: new functions implementing a simplified GArray. This GPtrArray is an array of gpointers and has functions to add and remove elements, much like java.lang.Vector. * garray.c: new functions for the single-byte special case of GArray. The functions g_byte_array* operate on arrays of bytes. Internally, a GArray is used. * testglib.c: tests for g_ptr_array, g_byte_array, and g_relation...
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 84f563524..d09d201b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,6 +23,7 @@ libglib_1_1_la_SOURCES = \
gslist.c \
gtimer.c \
gtree.c \
+ grel.c \
gstring.c \
gscanner.c \
gutils.c