summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>2001-04-03 13:15:41 +0000
committerTim Janik <timj@src.gnome.org>2001-04-03 13:15:41 +0000
commitbdd9b28b5bf43d3e60acc90da7564877214aac30 (patch)
tree70c9460eb9ef971653754e603fb63bb6ba0e3167 /Makefile.am
parent72cab5027f3b61424261a24ef96f0bc92fedd182 (diff)
downloadglib-bdd9b28b5bf43d3e60acc90da7564877214aac30.tar.gz
added g_list_nth_prev() which walks ->prev instead of ->next.
Tue Apr 3 13:46:22 2001 Tim Janik <timj@gtk.org> * glist.[hc]: added g_list_nth_prev() which walks ->prev instead of ->next. * gpattern.[hc]: added shell-style pattern matching code from beast, derived from the gtk_pattern_*() code, but with a couple of bug fixes and a number of optimizations. Tue Apr 3 14:06:00 2001 Tim Janik <timj@gtk.org> * gparam.[hc]: added g_param_spec_pool_list() to list pspecs per owner_type. the pspecs are not referenced, so the caller is supposed to have some idea about owner_type not randomly nuking his pspec's. if this is going to provide problems in the future, we can either auto-ref the pspecs, or add a _foreach variant, though the latter would have to invoke the callback while pspec's mutex is acquired, so i just went for the _list variant for now. * gclosure.h (G_CALLBACK): made GCallback a void (*) (void) fucntion.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 846fde012..c378bd730 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,7 @@ libglib_1_3_la_SOURCES = \
gmem.c \
gmessages.c \
gnode.c \
+ gpattern.c \
gprimes.c \
gqsort.c \
gqueue.c \
@@ -115,6 +116,7 @@ glibinclude_HEADERS = \
gmem.h \
gmessages.h \
gnode.h \
+ gpattern.h \
gprimes.h \
gqsort.h \
gquark.h \