summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2007-11-09 23:40:41 +0000
committerMatthias Clasen <matthiasc@src.gnome.org>2007-11-09 23:40:41 +0000
commit284c7e559bb1c4bac8c79e6adde3eb53a2965096 (patch)
tree387469395bdad9bb3b9e5232362be24ac92fcea0 /Makefile.am
parent6a647baed8ac3cd28554f29a0235cfff0b1acbcd (diff)
downloadglib-284c7e559bb1c4bac8c79e6adde3eb53a2965096.tar.gz
Add AM_PROG_CC_C_O.
2007-11-09 Matthias Clasen <mclasen@redhat.com> * configure.in: Add AM_PROG_CC_C_O. * Makefile.am: Remove the install-exec-local hook and use configexecincludedir_DATA instead, in an attempt to avoid automake 1.9 <> 1.10 incompatibilities. * glib/Makefile.am: Rename MIRRORING_TAB_SOURCES, since automake 1.10 complains. svn path=/trunk/; revision=5848
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 38c719c46..f685cf2ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,6 +10,7 @@ INCLUDES = -DG_LOG_DOMAIN=g_log_domain_glib @GLIB_DEBUG_FLAGS@ \
-DG_DISABLE_DEPRECATED -DGLIB_COMPILATION
EXTRA_DIST = \
+ ChangeLog.pre-2-14 \
ChangeLog.pre-2-12 \
ChangeLog.pre-2-10 \
ChangeLog.pre-2-8 \
@@ -28,6 +29,7 @@ EXTRA_DIST = \
HACKING \
MAINTAINERS \
autogen.sh \
+ mkinstalldirs \
makefile.msc \
glibconfig.h.win32.in \
msvc_recommended_pragmas.h \
@@ -55,13 +57,7 @@ BUILT_EXTRA_DIST = \
gtk-doc.make
configexecincludedir = $(libdir)/glib-2.0/include
-#configexecinclude_DATA = glibconfig.h
-
-install-exec-local: glibconfig.h
- $(MKDIR_P) $(DESTDIR)$(configexecincludedir)
- file=$(DESTDIR)$(configexecincludedir)/glibconfig.h; \
- if test -r $$file && cmp -s glibconfig.h $$file; then :; \
- else $(INSTALL_DATA) glibconfig.h $$file; fi
+configexecinclude_DATA = glibconfig.h
uninstall-local:
rm -f $(DESTDIR)$(configexecincludedir)/glibconfig.h