summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastian Wilhelmi <wilhelmi@ira.uka.de>1999-06-17 15:39:31 +0000
committerSebastian Wilhelmi <wilhelmi@src.gnome.org>1999-06-17 15:39:31 +0000
commit90f6cc9bf2453e5da385b2d547704091dd8afbb8 (patch)
tree185b523416ce210680c328dc2dbeae90d349d731 /Makefile.am
parented49525102be3f9db6300dae0d369a92c19b2e66 (diff)
downloadglib-90f6cc9bf2453e5da385b2d547704091dd8afbb8.tar.gz
Completed the thread support in GLib. Thread creation, prioritizing
1999-06-17 Sebastian Wilhelmi <wilhelmi@ira.uka.de> * configure.in, acglib.m4, acconfig.h, glib.h, gthread.c: Completed the thread support in GLib. Thread creation, prioritizing threads, yielding, joining threads as well as reader/writer locks and recursive mutexes are now in place. Please test heavily on your platform. It is so far tested on Linux/i386/pthreads, Solaris/Sparc/pthreads and Solaris/Sparc/solaristhreads. * gtimer.c, glib.h: Implement g_usleep (gulong microseconds) for thread safe sleeping. (sleep() is not MT-safe at all!) * gutils.c: Avoid compiler warning. * tests/Makefile.am, tests/thread-test.c: New program to test some aspects of the thread implementation. * gthread.c, Makefile.am: Renamed from gmutex.c to reflect the change of content. * configure.in: Purged all appearances of nspr. * gthread/gthread-posix.c, gthread-solaris.c: Added the native implementations for the GLib's extended thread support. * gthread/gthread-nspr.c: Removed for good. NSPR is nothing we would want to build upon. * gthread/gthread.c: Renamed to gthread-impl.c to avoid confusion with ../gthread.c (Formerly known as the file called gmutex.c) * gthread/testgthread.c: Removed. The new and much extended tests are in ../tests/thread-test.c. * gthread/Makefile.am: Changed to reflect the changes above.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 07256917b..f5a8c471a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,7 +40,6 @@ libglib_la_SOURCES = \
gmain.c \
gmem.c \
gmessages.c \
- gmutex.c \
gnode.c \
gprimes.c \
gqueue.c \
@@ -51,6 +50,7 @@ libglib_la_SOURCES = \
gstack.c \
gstrfuncs.c \
gstring.c \
+ gthread.c \
gtimer.c \
gtree.c \
gutils.c