summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@src.gnome.org>1999-05-08 14:14:32 +0000
committerTor Lillqvist <tml@src.gnome.org>1999-05-08 14:14:32 +0000
commitf6eb31132ca00fbf54cbaa9660b12cc8b5582252 (patch)
treeba4a14fa0596a5e2ac3c67928ca55572fd1f6e0c /Makefile.am
parent0e7f2f16f7c8b2ebfc0c8e8ed0761d665542a420 (diff)
downloadglib-f6eb31132ca00fbf54cbaa9660b12cc8b5582252.tar.gz
Correct rules for making the win32-related files that are made from
* Makefile.am tests/Makefile.am: Correct rules for making the win32-related files that are made from corresponding .in files. Is there a cleaner way than explicitly writing rules that invoke config.status?
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ddc8eeed9..07256917b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -89,16 +89,16 @@ testgdateparser_LDADD = libglib.la
m4datadir = $(datadir)/aclocal
m4data_DATA = glib.m4
-glibconfig.h.win32: $(top_builddir)/config.status glibconfig.h.win32.in
+glibconfig.h.win32: $(top_builddir)/config.status $(top_srcdir)/glibconfig.h.win32.in
cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
-config.h.win32: $(top_builddir)/config.status config.h.win32.in
+config.h.win32: $(top_builddir)/config.status $(top_srcdir)/config.h.win32.in
cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
-makefile.msc: $(top_builddir)/config.status makefile.msc.in
+makefile.msc: $(top_builddir)/config.status $(top_srcdir)/makefile.msc.in
cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
-makefile.cygwin: $(top_builddir)/config.status makefile.cygwin.in
+makefile.cygwin: $(top_builddir)/config.status $(top_srcdir)/makefile.cygwin.in
cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
.PHONY: files release sanity snapshot