summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2001-06-07 16:39:54 +0000
committerHavoc Pennington <hp@src.gnome.org>2001-06-07 16:39:54 +0000
commitfab889b14d4c71cc3d45aee2f610fdad0aa16ab1 (patch)
treee97e3c308ab5b44c92e753f5a83e2785545a0862 /Makefile.am
parent632943f359274cef42a6a77d4fa43caeedef7d87 (diff)
downloadglib-fab889b14d4c71cc3d45aee2f610fdad0aa16ab1.tar.gz
subst GLIB_GENMARSHAL, GOBJECT_QUERY, GLIB_MKENUMS variables
2001-06-07 Havoc Pennington <hp@redhat.com> * m4macros/glib-2.0.m4: subst GLIB_GENMARSHAL, GOBJECT_QUERY, GLIB_MKENUMS variables * gmodule-2.0.pc.in: add gmodule_supported variable * glib-2.0.pc.in: add glib_genmarshal, gobject_query, glib_mkenums variables * configure.in: put G_MODULE_SUPPORTED value into .pc files * autogen.sh: support AUTOGEN_SUBDIR_MODE * Makefile.am: add -uninstalled.pc.in to EXTRA_DIST 2001-06-07 Havoc Pennington <hp@redhat.com> * pango/Makefile.am: add libpango.la to _DEPENDENCIES for the other libs * configure.in: use AM_PATH_GLIB_2_0 * autogen.sh: support AUTOGEN_SUBDIR_MODE * Makefile.am: dist the .pc.in files 2001-06-07 Havoc Pennington <hp@redhat.com> * atk/Makefile.am: use @GLIB_GENMARSHAL@ so we can use uninstalled glib-genmarshal * configure.in: rearrange the library checks to support uninstalled linking * autogen.sh: add support for AUTOGEN_SUBDIR_MODE * atk-uninstalled.pc.in: new file, allows linking to uninstalled ATK in giant GTK tarball 2001-06-07 Havoc Pennington <hp@redhat.com> * tests/Makefile.am: add missing -I flag * gtk/Makefile.am: use @GLIB_MKENUMS@, @GLIB_GENMARSHAL@, etc. * configure.in: use pkg-config to see if GModule is supported; fix to properly turn on included loaders when GModule isn't supported; don't use AC_CHECK_LIB when libs are not installed yet * autogen.sh: add support for AUTOGEN_SUBDIR_MODE * Makefile.am (SUBDIRS): add m4macros subdir * gtk/Makefile.am: $(srcdir)/foo targets must be $(srcdir)/foo in dependencies also.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a532aebff..11b4e82d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,10 @@ EXTRA_DIST = \
gobject-2.0.pc.in \
gmodule-2.0.pc.in \
gthread-2.0.pc.in \
+ glib-2.0-uninstalled.pc.in \
+ gobject-2.0-uninstalled.pc.in \
+ gmodule-2.0-uninstalled.pc.in \
+ gthread-2.0-uninstalled.pc.in \
gen-unicode-tables.pl
# These may be in the builddir too