summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorCDT 1999 Shawn T. Amundson <amundson@gtk.org>1999-05-08 07:40:44 +0000
committerShawn Amundson <amundson@src.gnome.org>1999-05-08 07:40:44 +0000
commit499c9786d1316bc72c539d55786bb3a65d95a83a (patch)
tree9af442bcdb994b2d8f4ae926d0ed0eb1edfdf02a /configure.in
parent2b688f549c8a2719544b33859cdc5ef99355cf37 (diff)
downloadglib-499c9786d1316bc72c539d55786bb3a65d95a83a.tar.gz
Port to BeOS by myself and Richard Offer.
Sat May 8 01:52:29 CDT 1999 Shawn T. Amundson <amundson@gtk.org> * configure.in gerror.c gmain.c gstrfuncs.c gutils.c ltconfig ltmain.sh gmodule/Makefile.am gmodule/gmodule.c gmodule/gmoduleconf.h.in gmodule/gmodule-beos.c gthread/Makefile.am: Port to BeOS by myself and Richard Offer.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ea969fd86..03b58ffc3 100644
--- a/configure.in
+++ b/configure.in
@@ -78,6 +78,19 @@ AM_MAINTAINER_MODE
AC_CANONICAL_HOST
+AC_MSG_CHECKING(for the BeOS)
+case $host in
+ *-*-beos*)
+ AC_DEFINE(GLIB_NATIVE_BEOS, 1)
+ glib_native_beos="yes"
+ AC_MSG_RESULT([$glib_native_beos])
+ ;;
+ default)
+ glib_native_beos="no"
+ AC_MSG_RESULT($glib_native_beos)
+ ;;
+esac
+
dnl figure debugging default, prior to $ac_help setup
dnl
AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
@@ -446,6 +459,7 @@ dnl ***********************
dnl *** g_module checks ***
dnl ***********************
G_MODULE_LIBS=
+G_MODULE_PLUGIN_LIBS=
G_MODULE_LDFLAGS=
dnl G_MODULE_IMPL= don't reset, so cmd-line can override
G_MODULE_NEED_USCORE=0
@@ -458,6 +472,14 @@ if test -z "$G_MODULE_IMPL"; then
,)
,)
fi
+dnl *** load_image (BeOS)
+if test -z "$G_MODULE_IMPL" -a "x$glib_native_beos" = "xyes"; then
+ AC_CHECK_LIB(root, load_image,
+ G_MODULE_LIBS="-lbe -lroot -L\$(top_builddir_full)/.libs -lglib"
+ G_MODULE_PLUGIN_LIBS="-L\$(top_builddir_full)/gmodule/.libs -lgmodule"
+ G_MODULE_IMPL=G_MODULE_IMPL_BEOS
+,)
+fi
dnl *** dlopen() and dlsym() in libdl
if test -z "$G_MODULE_IMPL"; then
AC_CHECK_LIB(dl, dlopen,
@@ -540,6 +562,7 @@ if test -z "$G_MODULE_IMPL"; then
fi
AC_SUBST(G_MODULE_IMPL)
AC_SUBST(G_MODULE_LIBS)
+AC_SUBST(G_MODULE_PLUGIN_LIBS)
AC_SUBST(G_MODULE_LDFLAGS)
AC_SUBST(G_MODULE_HAVE_DLERROR)
AC_SUBST(G_MODULE_NEED_USCORE)
@@ -708,6 +731,15 @@ if test "x$G_THREAD_LIBS" = xerror; then
AC_MSG_ERROR($LIBS_NOT_FOUND_1$have_threads$LIBS_NOT_FOUND_2)
fi
+case $host in
+ *-*-beos*)
+ G_THREAD_LIBS="-lbe -lroot -L\$(top_builddir_full)/.libs -lglib "
+ ;;
+ *)
+ ;;
+esac
+
+
AC_MSG_CHECKING(thread related libraries)
AC_MSG_RESULT($G_THREAD_LIBS)
@@ -1258,6 +1290,11 @@ g_threads_impl_def=$g_threads_impl
g_mutex_has_default="$mutex_has_default"
g_mutex_sizeof="$glib_cv_sizeof_gmutex"
g_mutex_contents="$glib_cv_byte_contents_gmutex"
+
+if test "x$glib_native_beos" = "xyes"; then
+ glib_native_beos_def="\$glib_native_beos_def
+#define GLIB_NATIVE_BEOS 1"
+fi
])
AC_OUTPUT([