summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Wilhelmi <wilhelmi@ira.uka.de>1999-03-17 01:05:49 +0000
committerTim Janik <timj@src.gnome.org>1999-03-17 01:05:49 +0000
commit5f17e39e2a19abd133d5d74bd1a9abb619320432 (patch)
treecc1ee089fa35e12fcfa72c8ea08ff0735703736b /configure.in
parent5d1e3dc14e88f446bf15a40121f3fb56bf3d62bc (diff)
downloadglib-5f17e39e2a19abd133d5d74bd1a9abb619320432.tar.gz
Sun Mar 14 17:50:35 1999 Tim Janik <timj@gtk.org>
Wed Mar 17 01:46:28 1999 Tim Janik <timj@gtk.org> * merges from glib-1-2: Sun Mar 14 17:50:35 1999 Tim Janik <timj@gtk.org> * gmem.c (g_mem_chunk_*): changed a bunch of g_assert() statements to g_return_if_fail(). (g_mem_profile): (g_mem_chunk_print): (g_mem_chunk_info): removed some extraneous "\n"s at the end of the log messages. * gtimer.c (g_timer_*): changed a bunch of g_assert() statements to g_return_if_fail(). * grel.c (g_*): changed a bunch of g_assert() statements to g_return_if_fail() and added some extra ones to check relation != NULL. Tue Mar 9 23:25:50 1999 Tim Janik <timj@gtk.org> * configure.in: check for working realloc (NULL,). * gmem.c (g_realloc): use malloc() for initial allocation on systems where realloc(NULL,) will not work (this is the case on SunOS, reported by Tom Geiger). Mon Mar 8 07:42:08 1999 Tim Janik <timj@gtk.org> * ghook.c (g_hook_unref): when !hook_list->is_setup, wrap the flag around the call to g_hook_free() to avoid spurious warnings (happens during destruction phase). 1999-03-02 Sebastian Wilhelmi <wilhelmi@ira.uka.de> * gmem.c: Fixed a stupid cut'n'paste error of mine. Thanks to Friedrich Dominicus <Friedrich.Dominicus@inka.de>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d765d2e0e..3df035a09 100644
--- a/configure.in
+++ b/configure.in
@@ -320,6 +320,22 @@ else
fi
fi
+dnl *** check for sane realloc() ***
+AC_MSG_CHECKING(whether realloc (NULL,) will work)
+AC_CACHE_VAL(glib_cv_sane_realloc,[
+ AC_TRY_RUN([
+ #include <stdlib.h>
+ int main() {
+ return realloc (0, sizeof (int)) == 0;
+ }],
+ glib_cv_sane_realloc=yes
+ AC_DEFINE(REALLOC_0_WORKS)
+ ,
+ glib_cv_sane_realloc=no
+ ,)
+])
+AC_MSG_RESULT($glib_cv_sane_realloc)
+
dnl **********************
dnl *** va_copy checks ***