summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Wilhelmi <wilhelmi@ira.uka.de>2000-03-21 15:21:41 +0000
committerSebastian Wilhelmi <wilhelmi@src.gnome.org>2000-03-21 15:21:41 +0000
commit66034865b17cde557bfba6d456eaaf2641c35bb5 (patch)
tree9e0d70e4e8058b1a88cb49bd578cf7530fbc5b43 /configure.in
parentcdb61955724cd0f97546a86421b52b4da66e8ae5 (diff)
downloadglib-66034865b17cde557bfba6d456eaaf2641c35bb5.tar.gz
always define G_GNUC_EXTENSION, even when not needed by GLib. That's
2000-03-21 Sebastian Wilhelmi <wilhelmi@ira.uka.de> * glib.h, configure.in, gutils.h: always define G_GNUC_EXTENSION, even when not needed by GLib. That's actually also the way, the GLib reference manual describes that macro. Therefore I had to remove the lonesome #include <glibconfig.h> in gutils.c, which doesn't seem to be needed there however. This change should make Ben Gertzfield <che@debian.org> happy. * gutils.c: Furthermore two warnings in gutils.c were voided, which crept in due to my last change.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index ebc5669ae..1ff844a55 100644
--- a/configure.in
+++ b/configure.in
@@ -1138,7 +1138,7 @@ _______EOF
if test -n "$gint64"; then
cat >>$outfile <<_______EOF
-${glib_warning_guard}#define G_HAVE_GINT64 1
+#define G_HAVE_GINT64 1
${glib_extension}typedef signed $gint64 gint64;
${glib_extension}typedef unsigned $gint64 guint64;
@@ -1348,7 +1348,6 @@ $ac_cv_sizeof_int)
gint64_format='"i"'
guint64_format='"u"'
glib_extension=
- glib_warning_guard=
gint64_constant='(val)'
;;
$ac_cv_sizeof_long)
@@ -1356,7 +1355,6 @@ $ac_cv_sizeof_long)
gint64_format='"li"'
guint64_format='"lu"'
glib_extension=
- glib_warning_guard=
gint64_constant='(val##L)'
;;
$ac_cv_sizeof_long_long)
@@ -1364,14 +1362,6 @@ $ac_cv_sizeof_long_long)
gint64_format='"'$glib_cv_long_long_format'i"'
guint64_format='"'$glib_cv_long_long_format'u"'
glib_extension='G_GNUC_EXTENSION '
- glib_warning_guard="
-#if defined (__GNUC__) && (__GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ >= 8))
-# define G_GNUC_EXTENSION __extension__
-#else
-# define G_GNUC_EXTENSION
-#endif
-
-"
gint64_constant='(G_GNUC_EXTENSION (val##LL))'
;;
esac