summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Wilhelmi <wilhelmi@ira.uka.de>1999-11-08 10:02:17 +0000
committerSebastian Wilhelmi <wilhelmi@src.gnome.org>1999-11-08 10:02:17 +0000
commit6d441ca5af3ef4211ada7b1f38f8c7e0955b381f (patch)
tree43bde62905fbb463c37c2af1c7eee28ecad74351 /configure.in
parentcafa1e2c15a9cbaad93e95fce8a740bea0ca20d7 (diff)
downloadglib-6d441ca5af3ef4211ada7b1f38f8c7e0955b381f.tar.gz
Make the test for getpwuid_r work on newer AIX versions, too. Still works
1999-11-08 Sebastian Wilhelmi <wilhelmi@ira.uka.de> * configure.in: Make the test for getpwuid_r work on newer AIX versions, too. Still works on Solaris and Linux. Patch from Craig Rodrigues <rodrigc@mediaone.net>.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 7b7a77b34..885b15308 100644
--- a/configure.in
+++ b/configure.in
@@ -861,15 +861,15 @@ if test x"$enable_threads" = xyes; then
fi
if test "$ac_cv_func_getpwuid_r" = "yes"; then
AC_MSG_CHECKING(whether getpwuid_r is posix like)
- # getpwuid_r(0, NULL, NULL, 0) is the signature on
- # solaris, if that is not found, the prog below won't
- # compile, then the posix signature is assumed as
- # the default.
- AC_TRY_COMPILE([#include <pwd.h>],
- [getpwuid_r(0, NULL, NULL, 0);],
- [AC_MSG_RESULT(no)],
- [AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_GETPWUID_R_POSIX)])
+ # The signature for the POSIX version is:
+ # int getpwuid_r(uid_t, struct passwd *, char *, size_t, struct passwd **)
+ AC_TRY_COMPILE([#include <pwd.h>
+ #include <sys/types.h>
+ #include <stdlib.h>],
+ [getpwuid_r((uid_t)0, NULL, NULL, (size_t)0, NULL);],
+ [AC_DEFINE(HAVE_GETPWUID_R_POSIX)
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)])
fi
fi
LIBS="$LIBS $G_THREAD_LIBS"