summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>1999-08-15 00:58:48 +0000
committerTim Janik <timj@src.gnome.org>1999-08-15 00:58:48 +0000
commit9c53053abe8af7482dbf7db52a2313cad4b11478 (patch)
tree05cf114abdc75287dfd1d54f2c4b4a186386b164 /configure.in
parent1c6c7f748956caae98a79be89120c537c2032b7e (diff)
downloadglib-9c53053abe8af7482dbf7db52a2313cad4b11478.tar.gz
eliminate memset() call, since string.h has not neccessarily been included
Sun Aug 15 02:47:14 1999 Tim Janik <timj@gtk.org> * glib.h (g_trash_stack_pop): eliminate memset() call, since string.h has not neccessarily been included prior to glib.h. Mon Aug 2 21:03:10 1999 Tim Janik <timj@gtk.org> * configure.in: added --enable-msg-prefix option. * gmessages.c (g_log_default_handler): feature "prg_name (pid:%u): " if --enable-msg-prefix was selected (use "(process:%u): " if g_get_prgname () returns NULL, along the lines of g_on_error_query).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c43f9ce91..8e65464ff 100644
--- a/configure.in
+++ b/configure.in
@@ -104,6 +104,7 @@ AC_DIVERT_POP()dnl
dnl declare --enable-* args and collect ac_help strings
AC_ARG_ENABLE(debug, [ --enable-debug=[no/minimum/yes] turn on debugging [default=$debug_default]],,enable_debug=$debug_default)
+AC_ARG_ENABLE(msg-prefix, [ --enable-msg-prefix turn on program name and PID prefixing of messages and warnings],,enable_msg_prefix=no)
AC_ARG_ENABLE(mem_check, [ --enable-mem-check turn on malloc/free sanity checking [default=no]],,enable_mem_check=no)
AC_ARG_ENABLE(mem_profile, [ --enable-mem-profile turn on malloc profiling atexit [default=no]],,enable_mem_profile=no)
AC_ARG_ENABLE(ansi, [ --enable-ansi turn on strict ansi [default=no]],
@@ -144,6 +145,10 @@ fi
AC_DEFINE_UNQUOTED(G_COMPILED_WITH_DEBUGGING, "${enable_debug}")
+if test "x$enable_msg_prefix" = "xyes"; then
+ AC_DEFINE_UNQUOTED(G_ENABLE_MSG_PREFIX, 1)
+fi
+
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_STDC