summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRaja R Harinath <harinath@src.gnome.org>1999-03-14 20:57:41 +0000
committerRaja R Harinath <harinath@src.gnome.org>1999-03-14 20:57:41 +0000
commitbfc21756e14e4600c916c00e6ee03e1c10e0cc01 (patch)
tree9b7f5eb131f928ed584c963e2bfde2ca54742736 /configure.in
parentcc7f8896079710aeb11e65020fb68c166dd66f07 (diff)
downloadglib-bfc21756e14e4600c916c00e6ee03e1c10e0cc01.tar.gz
Remove widechar tests and defines. (fd_set): Change the grep for `fd_mask'
* configure.in (glibconfig.h): Remove widechar tests and defines. (fd_set): Change the grep for `fd_mask' to search for `fd_set'. * gerror.c (fd_mask): Remove conditional typedef. It is not used elsewhere in the file. * gmain.c (fd_mask): Likewise.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in70
1 files changed, 1 insertions, 69 deletions
diff --git a/configure.in b/configure.in
index f95ebb8c2..b4fd2931d 100644
--- a/configure.in
+++ b/configure.in
@@ -310,7 +310,7 @@ AC_TRY_COMPILE([#include <sys/types.h>],
if test $gtk_ok = yes; then
AC_MSG_RESULT([yes, found in sys/types.h])
else
- AC_HEADER_EGREP(fd_mask, sys/select.h, gtk_ok=yes)
+ AC_HEADER_EGREP(fd_set, sys/select.h, gtk_ok=yes)
if test $gtk_ok = yes; then
AC_DEFINE(HAVE_SYS_SELECT_H)
AC_MSG_RESULT([yes, found in sys/select.h])
@@ -320,56 +320,6 @@ else
fi
fi
-# These are used only in GDK (gdki18n.h)
-# This stuff is here only so that we can define these
-# things in glibconfig.h. If gtk+ started using an installed
-# gdkconfig.h file, then the definitions would belong there.
-
-# Check for wchar.h
-
-AC_MSG_CHECKING(for wchar.h)
-AC_TRY_CPP([#include <wchar.h>], glib_wchar_h=yes, glib_wchar_h=no)
-if test $glib_wchar_h = yes; then
- AC_DEFINE(HAVE_WCHAR_H)
-fi
-AC_MSG_RESULT($glib_wchar_h)
-
-# Check for wctype.h (for iswalnum)
-
-AC_MSG_CHECKING(for wctype.h)
-AC_TRY_CPP([#include <wctype.h>], glib_wctype_h=yes, glib_wctype_h=no)
-if test $glib_wctype_h = yes; then
- AC_DEFINE(HAVE_WCTYPE_H)
-fi
-AC_MSG_RESULT($glib_wctype_h)
-
-oLIBS="$LIBS"
-# in Solaris 2.5, `iswalnum' is in -lw
-AC_CHECK_FUNC(iswalnum,,[AC_CHECK_LIB(w,iswalnum)])
-
-# The following is necessary for Linux libc-5.4.38
-AC_MSG_CHECKING(if iswalnum() and friends are properly defined)
-AC_TRY_LINK([#include <stdlib.h>],[
-#if (defined(HAVE_WCTYPE_H) || defined(HAVE_WCHAR_H))
-# ifdef HAVE_WCTYPE_H
-# include <wctype.h>
-# else
-# ifdef HAVE_WCHAR_H
-# include <wchar.h>
-# endif
-# endif
-#else
-# define iswalnum(c) ((wchar_t)(c) <= 0xFF && isalnum(c))
-#endif
-iswalnum((wchar_t) 0);
-], glib_working_wctype=yes, glib_working_wctype=no)
-LIBS="$oLIBS"
-
-if test $glib_working_wctype = no; then
- AC_DEFINE(HAVE_BROKEN_WCTYPE)
-fi
-AC_MSG_RESULT($glib_working_wctype)
-
dnl **********************
dnl *** va_copy checks ***
@@ -1038,12 +988,7 @@ _______EOF
cat glibconfig-sysdefs.h >>$outfile
fi
-
cat >>$outfile <<_______EOF
-
-$glib_wc
-
-
#ifdef __cplusplus
}
#endif /* __cplusplus */
@@ -1217,19 +1162,6 @@ x$ac_cv_c_bigendian)
;;
esac
-if test x$glib_wchar_h = xyes; then
- glib_wc='
-#define G_HAVE_WCHAR_H 1'
-fi
-if test x$glib_wctype_h = xyes; then
- glib_wc="\$glib_wc
-#define G_HAVE_WCTYPE_H 1"
-fi
-if test x$glib_working_wctype = xno; then
- glib_wc="\$glib_wc
-#define G_HAVE_BROKEN_WCTYPE 1"
-fi
-
case x$enable_threads in
xyes) g_enable_threads_def="#define";;
*) g_enable_threads_def="#undef ";;