summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Gertzfield <che@src.gnome.org>1998-11-17 09:24:21 +0000
committerBen Gertzfield <che@src.gnome.org>1998-11-17 09:24:21 +0000
commit87bfdee04dc5591c4f7fb4559deca823afe020a8 (patch)
treed22b20216561414da5324ad766e7ed3205ec8708 /debian
parent5b0bbc292412b80ec590f6ab91097534061af3ec (diff)
downloadglib-87bfdee04dc5591c4f7fb4559deca823afe020a8.tar.gz
Added Debian CVS build scripts. To build a snapshot Debian release,
simply run, from within the top level of the glib directory: [ben@gilgamesh:~/src/gtk-snap/glib]% debian/build 1:16AM This will build a Debian snapshot release, updating debian/changelog, and place the resultant .debs in .. (~/src/gtk-snap/ in this example). The version numbers are automatically updated, and look like: YYYYMMDD.XX where YYYY is the four-digit year (Y10K problem!) and MM is the month (01-12) and DD is the day (01-31). XX is the build number; it starts at 01 and debian/build increments it if you build from CVS more than once in a day. If you're doing more than 99 CVS builds in one day you need your head checked. *NOTE*! The debian/build script I've written does not check in the changes it has made to debian/changelog; that'd be scary and probably generate too many log files all the time. This really doesn't matter *too* much, since debian/changelog is kind of irrelevant with CVS builds. Just know that the scant information that is in there will not be updated via CVS. Also, for obvious reasons, the debian/build script I've written disables PGP signing of the resultant .changes and .dsc file. Since these packages are not going into any archives, this will not be a problem. Of course, all this doesn't mean much to you if you don't have the Debian dpkg-dev tools and debhelper installed, so don't worry if you have no idea what I'm talking about. :)
Diffstat (limited to 'debian')
-rw-r--r--debian/README.debian30
-rwxr-xr-xdebian/build62
-rw-r--r--debian/changelog10
-rw-r--r--debian/control51
-rw-r--r--debian/copyright8
-rw-r--r--debian/libglib-cvs-dev.files9
-rw-r--r--debian/postinst7
-rwxr-xr-xdebian/rules126
8 files changed, 303 insertions, 0 deletions
diff --git a/debian/README.debian b/debian/README.debian
new file mode 100644
index 000000000..571f84d09
--- /dev/null
+++ b/debian/README.debian
@@ -0,0 +1,30 @@
+glib CVS snapshots for Debian
+-----------------------------
+
+This is GLib version 1.1. GLib, is a library which includes support
+routines for C such as lists, trees, hashes, memory allocation, and
+many other things.
+
+Versions of GLib prior to 1.1.0 are distributed with GTK+ versions 1.1.0
+and earlier.
+
+This is a snapshot of GLib from the main CVS archive, built into a
+Debian package. This package is not guaranteed to work, as it was
+built automatically. You're on your own, mister or missus!
+
+The GIMP Tool Kit (gtk) is a set of widgets to help you program
+programs for the X Windowing System easily and powerfully.
+
+gtk is the moving force behind The GNU Image Manipulation Program (The
+GIMP) -- the number one freely-available image editing and creation
+program available.
+
+gtk is rapidly under development, and the source tree has officially
+been separated from The GIMP now, as other teams of programmers
+are beginning to write software using its great widget set -- like
+GNOME, a desktop interface for X, and gzilla, a freely available
+web browser for X.
+
+Ben Gertzfield <che@debian.org>, Tue, 17 Nov 1998 00:06:12 -0800
+
+
diff --git a/debian/build b/debian/build
new file mode 100755
index 000000000..7a70d07bb
--- /dev/null
+++ b/debian/build
@@ -0,0 +1,62 @@
+#!/usr/bin/perl -w
+
+ # Adjust debian/changelog and build a new
+ # Debian package of a CVS archive.
+
+ # Written 17 November 1998 by Ben Gertzfield
+ # <che@debian.org>
+
+ # This work is released under the GNU
+ # General Public License, version 2 or
+ # later.
+
+use strict;
+use diagnostics;
+use File::Copy;
+
+my $maintainer = 'Ben Gertzfield <che@debian.org>';
+
+my @date = localtime;
+
+my $datestr = sprintf("%d%.2d%.2d", $date[5] + 1900, $date[4] + 1, $date[3]);
+my $revision = '01';
+
+open (CHANGELOG, 'debian/changelog') or die "Couldn't open debian/changelog: $!\n";
+
+$_ = <CHANGELOG>;
+chomp;
+
+close CHANGELOG;
+
+my ($package, $last_date, $last_revision) = /^(.*?) \((.*?)\.(.*)?\)/;
+
+if ($last_date eq $datestr) {
+ $revision = sprintf("%.2d", $last_revision + 1);
+}
+
+my $new_version = "$datestr.$revision";
+
+copy('debian/changelog', 'debian/changelog.old') or die "Couldn't copy debian/changelog to debian/changelog.old: $!\n";
+
+open(NEWCHANGELOG, ">debian/changelog") or die "Couldn't open debian/changelog for writing: $!\n";
+
+print NEWCHANGELOG "$package ($new_version) unstable; urgency=low\n\n * CVS snapshot build at " . scalar localtime() . "\n\n -- $maintainer " . `date -R` . "\n";
+
+open(OLDCHANGELOG, "debian/changelog.old") or die "Couldn't open debian/changelog.old: $!\n";
+
+while (<OLDCHANGELOG>) {
+ print NEWCHANGELOG;
+}
+
+close OLDCHANGELOG;
+close NEWCHANGELOG;
+
+unlink('debian/changelog.old') or die "Couldn't unlink debian/changelog.old: $!\n";
+
+open(NEWVERSION, '>debian/version') or die "Couldn't open debian/version for writing: $!\n";
+print NEWVERSION $new_version;
+close NEWVERSION;
+
+system('dpkg-buildpackage -rfakeroot -us -uc');
+unlink 'debian/version' or die "Couldn't unlink debian/version: $!\n";
+
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 000000000..6b5e22d09
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,10 @@
+glib-cvs (19981116.01) unstable; urgency=low
+
+ * Testing the CVS build scripts
+
+ -- Ben Gertzfield <che@debian.org> Tue, 17 Nov 1998 00:07:26 -0800
+
+Local variables:
+mode: debian-changelog
+add-log-mailing-address: "che@debian.org"
+End:
diff --git a/debian/control b/debian/control
new file mode 100644
index 000000000..725c18e52
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,51 @@
+Source: glib-cvs
+Priority: extra
+Section: libs
+Maintainer: Ben Gertzfield <che@debian.org>
+Standards-Version: 2.4.0.0
+
+Package: libglib-cvs-1.1
+Architecture: any
+Section: libs
+Depends: ${shlibs:Depends}
+Suggests: libgtk-cvs-1.1
+Conflicts: libglib1.1
+Description: CVS build of the GLib library of C routines
+ **THIS IS NOT AN OFFICIAL DEBIAN PACKAGE! THIS IS AN AUTOMATED CVS
+ BUILD OF THE GLIB LIBRARIES! BEWARE! IT MAY NOT WORK!**
+ .
+ GLib is a library containing many useful C routines for things such
+ as trees, hashes, and lists. GLib was previously distributed with
+ the GTK+ toolkit, but has been split off as of the developers' version
+ 1.1.0.
+
+Package: libglib-cvs-dev
+Architecture: any
+Section: devel
+Conflicts: libgtk-dev, libglib1.1-dev
+Depends: libglib-cvs-1.1 (=${Source-Version})
+Suggests: libgtk-cvs-dev, libgtk-cvs-1.1-doc
+Description: CVS header files and static libraries for the GLib library
+ **THIS IS NOT AN OFFICIAL DEBIAN PACKAGE! THIS IS AN AUTOMATED CVS
+ BUILD OF THE GLIB LIBRARIES! BEWARE! IT MAY NOT WORK!**
+ .
+ This package contains the header files and static libraries for the
+ GLib C library.
+ .
+ Install this package if you wish to develop your own X programs using
+ the GTK+ widget toolkit, or wish to develop plug-ins for The GIMP.
+
+Package: libglib-cvs-dbg
+Architecture: any
+Section: devel
+Conflicts: libgtk-dev, libglib-dbg
+Depends: libglib-cvs-1.1 (=${Source-Version}), libglib-cvs-dev (=${Source-Version})
+Description: CVS debugging static libraries for the GLib library
+ **THIS IS NOT AN OFFICIAL DEBIAN PACKAGE! THIS IS AN AUTOMATED CVS
+ BUILD OF THE GLIB LIBRARIES! BEWARE! IT MAY NOT WORK!**
+ .
+ This package contains the debugging static libraries for the GLib C
+ library.
+ .
+ The debugging libraries are installed as /usr/lib/libglib_g.a -- link
+ specifically with them if you want to debug.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 000000000..27fab203e
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,8 @@
+This package was debianized by Ben Gertzfield <che@debian.org>
+on Tue, 17 Nov 1998 00:16:10 -0800
+
+It was downloaded from the CVS archives at cvs.gimp.org.
+
+It may be redistributed under the terms of the GNU LGPL, Version 2 or
+later, found on Debian systems in the file /usr/doc/copyright/LGPL.
+
diff --git a/debian/libglib-cvs-dev.files b/debian/libglib-cvs-dev.files
new file mode 100644
index 000000000..4d95cfe74
--- /dev/null
+++ b/debian/libglib-cvs-dev.files
@@ -0,0 +1,9 @@
+usr/lib/libglib.so
+usr/lib/libglib.a
+usr/lib/libgmodule.so
+usr/lib/libgmodule.a
+usr/include/glib.h
+usr/include/gmodule.h
+usr/bin/glib-config
+usr/lib/glib/
+usr/share/aclocal/glib.m4
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 000000000..0cd5f28c9
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+set -e
+
+ldconfig
+
+#DEBHELPER#
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..7f06abbcf
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,126 @@
+#!/usr/bin/make -f
+
+# debian/rules file for CVS glib1.1 Debian package
+# based on glib+ debian/rules file
+# written April 1998 by Ben Gertzfield <che@debian.org>
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ ./autogen.sh --prefix=/usr
+ $(MAKE)
+ touch build-stamp
+
+build-dbg: build-dbg-stamp
+build-dbg-stamp:
+ dh_testdir
+ ./configure --prefix=/usr --enable-debug=yes
+ $(MAKE)
+ touch build-dbg-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp build-dbg-stamp install-stamp install-dbg-stamp
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+ -$(MAKE) distclean
+ find . -name '*.o' -o -name '_libs' -o -name '*.lo' -o -name '*.a' -o -name '.deps' | xargs rm -rf
+ dh_clean
+
+clean-dbg:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp build-dbg-stamp install-stamp install-dbg-stamp
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+ -$(MAKE) distclean
+ find . -name '*.o' -o -name '_libs' -o -name '*.lo' -o -name '*.a' -o -name '.deps' | xargs rm -rf
+ dh_clean -k
+
+install: install-stamp
+install-stamp: build
+ dh_testdir
+ dh_testroot
+ dh_clean
+ $(MAKE) prefix=`pwd`/debian/tmp/usr install
+ touch install-stamp
+
+install-dbg: install-dbg-stamp
+install-dbg-stamp: build-dbg
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ $(MAKE) prefix=`pwd`/debian/libglib-cvs-dbg/usr install
+ touch install-dbg-stamp
+
+# Build architecture-independent files here.
+binary-indep:
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install libglib-cvs-dev libglib-cvs-1.1 libglib-cvs-dbg
+
+libglib-cvs-1.1: build
+ dh_testdir -plibglib-cvs-1.1
+ dh_testroot -plibglib-cvs-1.1
+ dh_installdirs -plibglib-cvs-1.1
+ # Add here commands to install the files into debian/tmp
+ rm -rf debian/tmp/usr/bin debian/tmp/usr/include debian/tmp/usr/info debian/tmp/usr/lib/glib debian/tmp/usr/share debian/tmp/usr/man debian/tmp/usr/lib/*.la
+ dh_installdocs -plibglib-cvs-1.1
+ dh_installchangelogs -plibglib-cvs-1.1
+ dh_strip -plibglib-cvs-1.1
+ dh_compress -plibglib-cvs-1.1
+ dh_fixperms -plibglib-cvs-1.1
+ dh_installdeb -plibglib-cvs-1.1
+ dh_shlibdeps -plibglib-cvs-1.1
+ dh_gencontrol -plibglib-cvs-1.1
+ dh_makeshlibs -plibglib-cvs-1.1 -V 'libglib-cvs-1.1 (='`cat debian/version`')'
+ dh_md5sums -plibglib-cvs-1.1
+ dh_builddeb -plibglib-cvs-1.1
+
+libglib-cvs-dev: build
+ dh_testdir -plibglib-cvs-dev
+ dh_testroot -plibglib-cvs-dev
+ dh_clean -plibglib-cvs-dev -k
+ dh_installdirs -plibglib-cvs-dev
+ # Add here commands to install the files into debian/tmp
+ dh_movefiles -plibglib-cvs-dev
+ cp glib-config debian/tmp/usr/bin
+ dh_installdocs -plibglib-cvs-dev
+ dh_undocumented -plibglib-cvs-dev glib-config.1
+ dh_installchangelogs -plibglib-cvs-dev
+ dh_strip -plibglib-cvs-dev
+ dh_compress -plibglib-cvs-dev
+ dh_fixperms -plibglib-cvs-dev
+ dh_installdeb -plibglib-cvs-dev
+ dh_shlibdeps -plibglib-cvs-dev
+ dh_gencontrol -plibglib-cvs-dev
+ dh_md5sums -plibglib-cvs-dev
+ dh_builddeb -plibglib-cvs-dev
+
+libglib-cvs-dbg: clean-dbg install-dbg
+ dh_testdir -plibglib-cvs-dbg
+ dh_testroot -plibglib-cvs-dbg
+ dh_installdirs -plibglib-cvs-dbg
+ # Add here commands to install the files into debian/libglib-cvs-dbg
+ rm -rf debian/libglib-cvs-dbg/usr/bin debian/libglib-cvs-dbg/usr/include debian/libglib-cvs-dbg/usr/info debian/libglib-cvs-dbg/usr/lib/glib debian/libglib-cvs-dbg/usr/man debian/libglib-cvs-dbg/usr/share debian/libglib-cvs-dbg/usr/lib/*.{la,so*}
+ for file in `find debian/libglib-cvs-dbg/usr/lib -name '*.a'` ; do \
+ mv $$file debian/libglib-cvs-dbg/usr/lib/`basename $$file .a`_g.a; \
+ done
+ dh_installdocs -plibglib-cvs-dbg
+ dh_installchangelogs -plibglib-cvs-dbg
+ dh_compress -plibglib-cvs-dbg
+ dh_fixperms -plibglib-cvs-dbg
+ dh_installdeb -plibglib-cvs-dbg
+ dh_shlibdeps -plibglib-cvs-dbg
+ dh_gencontrol -plibglib-cvs-dbg
+ dh_makeshlibs -plibglib-cvs-dbg -V
+ dh_md5sums -plibglib-cvs-dbg
+ dh_builddeb -plibglib-cvs-dbg
+
+source diff:
+ @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary