aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2018-07-09 01:40:08 -0700
committerEugene Kliuchnikov <eustas@google.com>2018-07-09 10:40:08 +0200
commitfc4d345968fd3a0f3a2875daffb484debdbe01bb (patch)
tree10bb9333b41b9f09f60dfff5f9bf6cd8738f120c /setup.py
parentb601fe817bd3217cb144bbb380a43cae8e847388 (diff)
downloadbrotli-fc4d345968fd3a0f3a2875daffb484debdbe01bb.tar.gz
Fix missing header files (#695)
Our dist tarball is missing hash_rolling_inc.h and hash_composite_inc.h, which causes subsequent autotools builds to fail. Fix this by adding it to the sources list. Signed-off-by: William A. Kennington III <william@wkennington.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7535fb2..1491db3 100644
--- a/setup.py
+++ b/setup.py
@@ -238,10 +238,12 @@ EXT_MODULES = [
'c/enc/fast_log.h',
'c/enc/find_match_length.h',
'c/enc/hash.h',
+ 'c/enc/hash_composite_inc.h',
'c/enc/hash_forgetful_chain_inc.h',
'c/enc/hash_longest_match64_inc.h',
'c/enc/hash_longest_match_inc.h',
'c/enc/hash_longest_match_quickly_inc.h',
+ 'c/enc/hash_rolling_inc.h',
'c/enc/hash_to_binary_tree_inc.h',
'c/enc/histogram.h',
'c/enc/histogram_inc.h',