aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorZoltan Szabadka <szabadka@google.com>2015-10-02 11:32:42 +0200
committerZoltan Szabadka <szabadka@google.com>2015-10-02 11:32:42 +0200
commitb5c92e54a632aaba44559839c79b820ea202f123 (patch)
tree89063a0af0f3b9f4760c50ca008adfd7afc9db46 /setup.py
parentcd2538b0a701efdd8dd7c5f6f8e727ea06629ee1 (diff)
downloadbrotli-b5c92e54a632aaba44559839c79b820ea202f123.tar.gz
Add tools/version.h that conatins the brotli version.
This can be reused by all of the tools. Set the version to the next git release tag.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 5b5e615..02547ff 100644
--- a/setup.py
+++ b/setup.py
@@ -24,8 +24,8 @@ if platform.system() == 'Windows':
def get_version():
- """ Return BROTLI_VERSION string as defined in 'brotlimodule.cc' file. """
- brotlimodule = os.path.join(CURR_DIR, 'python', 'brotlimodule.cc')
+ """ Return BROTLI_VERSION string as defined in 'tools/version.h' file. """
+ brotlimodule = os.path.join(CURR_DIR, 'tools', 'version.h')
with open(brotlimodule, 'r') as f:
for line in f:
m = re.match(r'#define\sBROTLI_VERSION\s"(.*)"', line)