aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt40
1 files changed, 33 insertions, 7 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 9dfc80b..dbbcb81 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -28,6 +28,13 @@
#
# Author: keir@google.com (Keir Mierle)
+# Only Ceres itself should be compiled with CERES_BUILDING_SHARED_LIBRARY
+# defined, any users of Ceres will have CERES_USING_SHARED_LIBRARY defined
+# for them in Ceres' config.h if appropriate.
+IF (BUILD_SHARED_LIBS)
+ REMOVE_DEFINITIONS(-DCERES_BUILDING_SHARED_LIBRARY)
+ENDIF()
+
ADD_EXECUTABLE(helloworld helloworld.cc)
TARGET_LINK_LIBRARIES(helloworld ceres)
@@ -42,7 +49,15 @@ TARGET_LINK_LIBRARIES(curve_fitting ceres)
ADD_EXECUTABLE(curve_fitting_c curve_fitting.c)
TARGET_LINK_LIBRARIES(curve_fitting_c ceres)
+# As this is a C file #including <math.h> we have to explicitly add the math
+# library (libm). Although some compilers (dependent upon options) will accept
+# the indirect link to libm via Ceres, at least GCC 4.8 on pure Debian won't.
+IF (NOT MSVC)
+ TARGET_LINK_LIBRARIES(curve_fitting_c m)
+ENDIF (NOT MSVC)
+ADD_EXECUTABLE(ellipse_approximation ellipse_approximation.cc)
+TARGET_LINK_LIBRARIES(ellipse_approximation ceres)
ADD_EXECUTABLE(robust_curve_fitting robust_curve_fitting.cc)
TARGET_LINK_LIBRARIES(robust_curve_fitting ceres)
@@ -53,26 +68,37 @@ TARGET_LINK_LIBRARIES(simple_bundle_adjuster ceres)
IF (GFLAGS)
ADD_EXECUTABLE(powell powell.cc)
- TARGET_LINK_LIBRARIES(powell ceres)
+ TARGET_LINK_LIBRARIES(powell ceres ${GFLAGS_LIBRARIES})
ADD_EXECUTABLE(nist nist.cc)
- TARGET_LINK_LIBRARIES(nist ceres)
+ TARGET_LINK_LIBRARIES(nist ceres ${GFLAGS_LIBRARIES})
+
+ ADD_EXECUTABLE(more_garbow_hillstrom more_garbow_hillstrom.cc)
+ TARGET_LINK_LIBRARIES(more_garbow_hillstrom ceres ${GFLAGS_LIBRARIES})
ADD_EXECUTABLE(circle_fit circle_fit.cc)
- TARGET_LINK_LIBRARIES(circle_fit ceres)
+ TARGET_LINK_LIBRARIES(circle_fit ceres ${GFLAGS_LIBRARIES})
ADD_EXECUTABLE(bundle_adjuster
bundle_adjuster.cc
bal_problem.cc)
- TARGET_LINK_LIBRARIES(bundle_adjuster ceres)
+ TARGET_LINK_LIBRARIES(bundle_adjuster ceres ${GFLAGS_LIBRARIES})
ADD_EXECUTABLE(libmv_bundle_adjuster
libmv_bundle_adjuster.cc)
- TARGET_LINK_LIBRARIES(libmv_bundle_adjuster ceres)
+ TARGET_LINK_LIBRARIES(libmv_bundle_adjuster ceres ${GFLAGS_LIBRARIES})
+
+ ADD_EXECUTABLE(libmv_homography
+ libmv_homography.cc)
+ TARGET_LINK_LIBRARIES(libmv_homography ceres ${GFLAGS_LIBRARIES})
ADD_EXECUTABLE(denoising
denoising.cc
fields_of_experts.cc)
- TARGET_LINK_LIBRARIES(denoising ceres)
-ENDIF (GFLAGS)
+ TARGET_LINK_LIBRARIES(denoising ceres ${GFLAGS_LIBRARIES})
+
+ ADD_EXECUTABLE(robot_pose_mle
+ robot_pose_mle.cc)
+ TARGET_LINK_LIBRARIES(robot_pose_mle ceres ${GFLAGS_LIBRARIES})
+ENDIF (GFLAGS)