aboutsummaryrefslogtreecommitdiff
path: root/unittests/Format/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'unittests/Format/CMakeLists.txt')
-rw-r--r--unittests/Format/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/unittests/Format/CMakeLists.txt b/unittests/Format/CMakeLists.txt
index 01af435fff..240be6ead2 100644
--- a/unittests/Format/CMakeLists.txt
+++ b/unittests/Format/CMakeLists.txt
@@ -3,15 +3,20 @@ set(LLVM_LINK_COMPONENTS
)
add_clang_unittest(FormatTests
+ CleanupTest.cpp
FormatTest.cpp
FormatTestJava.cpp
FormatTestJS.cpp
FormatTestProto.cpp
FormatTestSelective.cpp
+ SortImportsTestJS.cpp
SortIncludesTest.cpp
)
target_link_libraries(FormatTests
+ clangBasic
clangFormat
+ clangFrontend
+ clangRewrite
clangToolingCore
)