aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Hines <srhines@google.com>2014-11-26 17:56:19 -0800
committerStephen Hines <srhines@google.com>2014-11-26 17:56:19 -0800
commit6d1862363c88c183b0ed7740fca876342cf0474b (patch)
treeb1ee2dcf9d8ba2bc92fda92ea82f331d1abad125 /test/CMakeLists.txt
parent45badb4fbfc53b8bebbcb431cb4b9807184da901 (diff)
downloadcompiler-rt-6d1862363c88c183b0ed7740fca876342cf0474b.tar.gz
Update aosp/master compiler-rt for rebase to r222486.
Change-Id: I38047809dbac0425193c82e810315998adbb380d
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 847721635..007ac3ff3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -14,7 +14,7 @@ if(NOT ANDROID)
# Use LLVM utils and Clang from the same build tree.
list(APPEND SANITIZER_COMMON_LIT_TEST_DEPS
clang clang-headers FileCheck count not llvm-nm llvm-symbolizer
- compiler-rt-headers)
+ compiler-rt-headers profile)
endif()
if(UNIX)
list(APPEND SANITIZER_COMMON_LIT_TEST_DEPS SanitizerLintCheck)
@@ -24,28 +24,28 @@ endif()
# Run sanitizer tests only if we're sure that clang would produce
# working binaries.
if(COMPILER_RT_CAN_EXECUTE_TESTS)
- if(ASAN_SUPPORTED_ARCH OR ANDROID)
+ if(COMPILER_RT_HAS_ASAN)
add_subdirectory(asan)
endif()
- if(DFSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_DFSAN)
add_subdirectory(dfsan)
endif()
- if(LSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_LSAN)
add_subdirectory(lsan)
endif()
- if(MSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_MSAN)
add_subdirectory(msan)
endif()
- if(PROFILE_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_PROFILE)
add_subdirectory(profile)
endif()
- if(SANITIZER_COMMON_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_SANITIZER_COMMON)
add_subdirectory(sanitizer_common)
endif()
- if(TSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_TSAN)
add_subdirectory(tsan)
endif()
- if(UBSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_UBSAN)
add_subdirectory(ubsan)
endif()
endif()