aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBas Hendri <dipidoo@users.noreply.github.com>2019-12-26 09:00:05 -0800
committerBas Hendri <dipidoo@users.noreply.github.com>2019-12-26 09:00:05 -0800
commit58d183d1d943189cb5cf1f116f1da23b8f60dd0d (patch)
tree15da477a1b3f8ab34b7f1b343645027bdef93497 /CMakeLists.txt
parentfd253b79f772f01464ac85870155cd78348e36c3 (diff)
downloadcpuinfo-58d183d1d943189cb5cf1f116f1da23b8f60dd0d.tar.gz
fixes iphonesimulator build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0426543..a71aede 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -140,7 +140,7 @@ IF(CPUINFO_SUPPORTED_PLATFORM)
LIST(APPEND CPUINFO_SRCS
src/x86/linux/init.c
src/x86/linux/cpuinfo.c)
- ELSEIF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ ELSEIF(CMAKE_SYSTEM_NAME STREQUAL "Darwin" OR CMAKE_SYSTEM_NAME STREQUAL "iOS")
LIST(APPEND CPUINFO_SRCS src/x86/mach/init.c)
ELSEIF(CMAKE_SYSTEM_NAME STREQUAL "Windows")
LIST(APPEND CPUINFO_SRCS src/x86/windows/init.c)