aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Knight <james.d.knight@live.com>2018-06-01 20:54:54 -0400
committerJames Knight <james.d.knight@live.com>2018-06-01 20:54:54 -0400
commit7de7b23f6e6b9da1b85a94dc781800ba4462bf27 (patch)
treee1e2c0d656d7f7ebc738338f985b0998f0688c5d /CMakeLists.txt
parentd6aeadaaf63a7cad20e6fcdd7c21862a76c4330c (diff)
downloadSPIRV-Headers-7de7b23f6e6b9da1b85a94dc781800ba4462bf27.tar.gz
cmake: support gnu installation directory convention
Support the handling of the `DESTDIR` environment variable for environments (UNIX-based) opting for an GNU-style installation over a CMake-style installation. Cc: sl1pkn07 <sl1pkn07@gmail.com> Signed-off-by: James Knight <james.d.knight@live.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b4ad4c7..2488baf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,6 +55,6 @@ endforeach()
# legacy
add_custom_target(install-headers
COMMAND cmake -E copy_directory ${CMAKE_CURRENT_SOURCE_DIR}/include/spirv
- ${CMAKE_INSTALL_PREFIX}/include/spirv)
+ $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/include/spirv)
add_subdirectory(example)