aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Tuganov <andreyt@google.com>2017-04-24 15:17:33 -0400
committerDavid Neto <dneto@google.com>2017-05-12 17:08:33 -0400
commit3eb716cae4ccbfb7e4d6d7d78c4488fb16fdc81a (patch)
tree84fa6569c1833d4596e92edc6cb884ab34a341d7 /test/CMakeLists.txt
parentf5facf842f10bda07f85db7661b5f71121891434 (diff)
downloadSPIRV-Tools-3eb716cae4ccbfb7e4d6d7d78c4488fb16fdc81a.tar.gz
Added bit stream utils
Also added generalized zigzag coding. - Due to signed integers being mostly non-negative, improved zigzag coding to favor positive values.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index dfddd09e..926dadef 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -164,6 +164,11 @@ add_spvtools_unittest(
SRCS preserve_numeric_ids_test.cpp
LIBS ${SPIRV_TOOLS})
+add_spvtools_unittest(
+ TARGET bit_stream
+ SRCS bit_stream.cpp
+ LIBS ${SPIRV_TOOLS})
+
add_subdirectory(opt)
add_subdirectory(val)
add_subdirectory(stats)