aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dj2@everburning.com>2019-05-24 15:43:59 -0400
committerSteven Perron <stevenperron@google.com>2019-05-24 15:43:59 -0400
commit42abaa099aab6ce5a1e7735e1caba89bab3d0327 (patch)
tree73dfd3cbfed0a0fc1d485f9a53b421b6ad59826b /test/CMakeLists.txt
parent3b5ab540ca83533f25bdab9c18e066e582b4730a (diff)
downloadSPIRV-Tools-42abaa099aab6ce5a1e7735e1caba89bab3d0327.tar.gz
Remove MarkV and Stats code. (#2576)
* Remove MarkV and Stats code. This Cl removes the MarkV and Stats code from SPIRV-Tools. This code was unused and currently un-maintained.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt24
1 files changed, 0 insertions, 24 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index bf0792cf..5def389d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -183,33 +183,9 @@ add_spvtools_unittest(
endif()
-add_spvtools_unittest(
- TARGET bit_stream
- SRCS bit_stream.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/../source/comp/bit_stream.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/../source/comp/bit_stream.h
- LIBS ${SPIRV_TOOLS})
-
-add_spvtools_unittest(
- TARGET huffman_codec
- SRCS huffman_codec.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/../source/comp/bit_stream.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/../source/comp/bit_stream.h
- ${CMAKE_CURRENT_SOURCE_DIR}/../source/comp/huffman_codec.h
- LIBS ${SPIRV_TOOLS})
-
-add_spvtools_unittest(
- TARGET move_to_front
- SRCS move_to_front_test.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/../source/comp/move_to_front.h
- ${CMAKE_CURRENT_SOURCE_DIR}/../source/comp/move_to_front.cpp
- LIBS ${SPIRV_TOOLS})
-
-add_subdirectory(comp)
add_subdirectory(link)
add_subdirectory(opt)
add_subdirectory(reduce)
-add_subdirectory(stats)
add_subdirectory(tools)
add_subdirectory(util)
add_subdirectory(val)