aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Neto <dneto@google.com>2019-12-19 17:16:26 -0500
committerGitHub <noreply@github.com>2019-12-19 17:16:26 -0500
commit64f36ea5296ec023f65f75d72196d3ff7ae7c7b2 (patch)
treeeba5f65c03b145f17eaca9fa48ac8f791a20c052 /test/CMakeLists.txt
parente01bc6d4e8467ecd92d1b57a4aca700788108275 (diff)
downloadSPIRV-Tools-64f36ea5296ec023f65f75d72196d3ff7ae7c7b2.tar.gz
Support OpenCL.DebugInfo.100 extended instruction set (#3080)
* Clone opencl.debuginfo.100 grammar from debuginfo grammar Update version number to 200 revision 2 * Apply content from OpenCL.DebugInfo.100 extension text * Rename grammar file * Support OpenCL.DebugInfo.100 extended instructions Add support for prefixing operand type names, to disambiguate them between different instruction sets. * Add tests for OpenCL.DebugInfo.100 * Support lookup of OpenCL.DebugInfo.100 extinst * Add tests for enum values * Recognize 2017-2019 as copyright date range * Android.mk: support OpenCL.DebugInfo.100 extended instruction set Also, stop generating core instruction tables for non-unified1 versions of the grammar. * Imported entity operand type is concrete * Bazel: Suppoort OpenCL.DebugInfo.100 * BUILD.gn: Support OpenCL.DebugInfo.100
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index e6857e04..70999f99 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -100,6 +100,7 @@ set(TEST_SOURCES
diagnostic_test.cpp
enum_string_mapping_test.cpp
enum_set_test.cpp
+ ext_inst.cldebug100_test.cpp
ext_inst.debuginfo_test.cpp
ext_inst.glsl_test.cpp
ext_inst.non_semantic_test.cpp