aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Perron <stevenperron@google.com>2017-10-10 09:47:01 -0400
committerDavid Neto <dneto@google.com>2017-10-12 12:40:18 -0400
commit720beb161a7c3802cbc086c05466b52e8f187e07 (patch)
tree65a45eccbd878ec3755fd3524d2ea2cbe7129ca4 /test/CMakeLists.txt
parent63064bd9eba297a6c2d0cc45564c753e8757be27 (diff)
downloadSPIRV-Tools-720beb161a7c3802cbc086c05466b52e8f187e07.tar.gz
Generic intrusive linked list class.
This commit is the initial implementation of the intrusive linked list class. It includes the implementation in the header files, and unit test. The iterators are circular: incrementing end() gives begin() and decrementing begin() gives end(). Also made it valid to decrement end(). Expliticly defines move constructor and move assignment - Visual Studio 2013 does not implicitly generate the move constructor or move assignments. So they need to be explicit, otherwise it will try to use the copy constructor, which we explicitly deleted. - Can't use "= default" either. Seems like VS2013 does not support explicitly using the default move constructors and move assignments, so I wrote them out.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 54aa97d4..1b8cad29 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -183,4 +183,5 @@ add_subdirectory(comp)
add_subdirectory(link)
add_subdirectory(opt)
add_subdirectory(stats)
+add_subdirectory(util)
add_subdirectory(val)