aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPierre Moreau <dev@pmoreau.org>2017-07-13 02:16:51 +0200
committerDavid Neto <dneto@google.com>2017-10-06 18:33:53 -0400
commit86627f7b3f725d390b6e09078db0f41f10c9d165 (patch)
treec23fb62e45ebdef060e07eac66cc862fe343d89f /test/CMakeLists.txt
parent4b1577a0cbcfdbdbbe540b7ba91945b70ac7fb46 (diff)
downloadSPIRV-Tools-86627f7b3f725d390b6e09078db0f41f10c9d165.tar.gz
Implement Linker (module combiner)
Add extra iterators for ir::Module's sections Add extra getters to ir::Function Add a const version of BasicBlock::GetLabelInst() Use the max of all inputs' version as version Split debug in debug1 and debug2 - Debug1 instructions have to be placed before debug2 instructions. Error out if different addressing or memory models are found Exit early if no binaries were given Error out if entry points are redeclared Implement copy ctors for Function and BasicBlock - Visual Studio ends up generating copy constructors that call deleted functions while compiling the linker code, while GCC and clang do not. So explicitly write those functions to avoid Visual Studio messing up. Move removing duplicate capabilities to its own pass Add functions running on all IDs present in an instruction Remove duplicate SpvOpExtInstImport Give default options value for link functions Remove linkage capability if not making a library Check types before allowing to link Detect if two types/variables/functions have different decorations Remove decorations of imported variables/functions and their types Add a DecorationManager Add a method for removing all decorations of id Add methods for removing operands from instructions Error out if one of the modules has a non-zero schema Update README.md to talk about the linker Do not freak out if an imported built-in variable has no export
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 8ebcd93b..54aa97d4 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -180,6 +180,7 @@ add_spvtools_unittest(
LIBS ${SPIRV_TOOLS})
add_subdirectory(comp)
+add_subdirectory(link)
add_subdirectory(opt)
add_subdirectory(stats)
add_subdirectory(val)