aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Tuganov <andreyt@google.com>2017-06-12 12:01:39 -0400
committerDavid Neto <dneto@google.com>2017-06-29 16:16:18 -0400
commit8d3882a40807f0df5d7b5c09239f47f6c209eb46 (patch)
treef11aa20888c1acb99905b9018d29143e556a7c08 /test/CMakeLists.txt
parent40a2829611c1ae4a629f4e6bc00bdf89e32ea67d (diff)
downloadSPIRV-Tools-8d3882a40807f0df5d7b5c09239f47f6c209eb46.tar.gz
Added log(n) move-to-front implementation
The implementation is based on AVL and order statistic tree. It accepts all kinds of values and the implementation doesn't expect the behaviour to be consistent with id coding. Intended by SPIR-V compression algorithms.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index c26de522..199143b3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -174,6 +174,11 @@ add_spvtools_unittest(
SRCS huffman_codec.cpp
LIBS ${SPIRV_TOOLS})
+add_spvtools_unittest(
+ TARGET move_to_front
+ SRCS move_to_front_test.cpp
+ LIBS ${SPIRV_TOOLS})
+
add_subdirectory(opt)
add_subdirectory(val)
add_subdirectory(stats)