aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Tuganov <andreyt@google.com>2017-03-10 15:58:15 -0500
committerDavid Neto <dneto@google.com>2017-03-14 13:39:43 -0400
commitb0116331718113de20af5b0a1cc869ccc95b13fa (patch)
treebc0f3f75643f5c58b66064ff105e5e88eecc2a30 /test/CMakeLists.txt
parent1fb8c37b5718118b49eec59dc383cfa3f98643c0 (diff)
downloadSPIRV-Tools-b0116331718113de20af5b0a1cc869ccc95b13fa.tar.gz
Validator checks if operands require extension
If required extension is not found, returning new error SPV_ERROR_MISSING_EXTENSION.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 3fc6719e..10b4cb09 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -147,6 +147,11 @@ add_spvtools_unittest(
LIBS ${SPIRV_TOOLS})
add_spvtools_unittest(
+ TARGET string_utils
+ SRCS string_utils_test.cpp
+ LIBS ${SPIRV_TOOLS})
+
+add_spvtools_unittest(
TARGET log
SRCS log_test.cpp
LIBS ${SPIRV_TOOLS})