aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Tuganov <andreyt@google.com>2017-03-15 17:28:24 -0400
committerDavid Neto <dneto@google.com>2017-03-16 15:29:17 -0400
commitc804c125c568914aabf4d734cf85923611bdfd21 (patch)
treeca7452d1e51b861435eb8f0ee327d65b6b28d539 /test/CMakeLists.txt
parentb0116331718113de20af5b0a1cc869ccc95b13fa (diff)
downloadSPIRV-Tools-c804c125c568914aabf4d734cf85923611bdfd21.tar.gz
Autogenererating enum-string mappings from grammar
Autogenerating the following code: - extension enum - extension-to-string - string-to-extension - capability-to-string Capability mapping table will not compile if incomplete. TODO: Use "spirv-latest-version.h" instead of 1.1. Added function to generate capability tables for tests.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 10b4cb09..79c2684d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -52,6 +52,7 @@ function(add_spvtools_unittest)
${spirv-tools_SOURCE_DIR}
${spirv-tools_SOURCE_DIR}/include
${spirv-tools_SOURCE_DIR}/test
+ ${spirv-tools_BINARY_DIR}
${gtest_SOURCE_DIR}/include
${gmock_SOURCE_DIR}/include
)
@@ -75,6 +76,7 @@ set(TEST_SOURCES
binary_to_text_test.cpp
binary_to_text.literal_test.cpp
comment_test.cpp
+ enum_string_mapping_test.cpp
enum_set_test.cpp
ext_inst.glsl_test.cpp
ext_inst.opencl_test.cpp