aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dj2@everburning.com>2019-01-07 16:00:43 -0500
committerGitHub <noreply@github.com>2019-01-07 16:00:43 -0500
commit6b3fb7328a3926d3ae8ed8b6d01cc66c0bb7d5e1 (patch)
tree593e7afc8a96316d2a0f355a14e7751d2ee5df33 /CMakeLists.txt
parent12ba79a206f1a540c7a97d62533580d4ac1d54ef (diff)
downloadamber-6b3fb7328a3926d3ae8ed8b6d01cc66c0bb7d5e1.tar.gz
Fixup various build warnings. (#210)
This CL fixes a series of build errors due to uint8_t conversions. An option to disable building the sample app is also added.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d2f576d..9aa7855 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,8 @@ option(AMBER_SKIP_SPIRV_TOOLS
"Skip building spirv-tools into the library" ${AMBER_SKIP_SPIRV_TOOLS})
option(AMBER_SKIP_SHADERC
"Skip building Shaderc into the library" ${AMBER_SKIP_SHADERC})
+option(AMBER_SKIP_SAMPLES
+ "Skip building sample application" ${AMBER_SKIP_SAMPLES})
if (${AMBER_SKIP_SPIRV_TOOLS})
set(AMBER_ENABLE_SPIRV_TOOLS FALSE)
@@ -57,10 +59,16 @@ if (${AMBER_SKIP_TESTS})
else()
set(AMBER_ENABLE_TESTS TRUE)
endif()
+if (${AMBER_SKIP_SAMPLES})
+ set(AMBER_ENABLE_SAMPLES FALSE)
+else()
+ set(AMBER_ENABLE_SAMPLES TRUE)
+endif()
message(STATUS "Amber enable SPIRV-Tools: ${AMBER_ENABLE_SPIRV_TOOLS}")
message(STATUS "Amber enable Shaderc: ${AMBER_ENABLE_SHADERC}")
message(STATUS "Amber enable tests: ${AMBER_ENABLE_TESTS}")
+message(STATUS "Amber enable samples: ${AMBER_ENABLE_SAMPLES}")
include_directories("${PROJECT_SOURCE_DIR}/include")
include_directories("${PROJECT_SOURCE_DIR}")
@@ -178,4 +186,7 @@ endfunction()
add_subdirectory(third_party)
add_subdirectory(src)
-add_subdirectory(samples)
+
+if (${AMBER_ENABLE_SAMPLES})
+ add_subdirectory(samples)
+endif()