aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dj2@everburning.com>2019-03-07 15:44:31 -0500
committerGitHub <noreply@github.com>2019-03-07 15:44:31 -0500
commit0d744484eba498e30ad02cfb91b35426df470ece (patch)
tree15e738f15a7c5e4f33a37b538700831bdadcdaa5 /CMakeLists.txt
parent6d37d69d4cde35d95f8420e879d1fa6543e4ff1c (diff)
downloadamber-0d744484eba498e30ad02cfb91b35426df470ece.tar.gz
Build with local vulkan data if requested (#319)
This CL adds a flag AMBER_USE_LOCAL_VULKAN which if set when running cmake will have amber use the vulkan header and loaders out of the third_party directory. This should let amber try to build on a system without vulkan so the build can be tested on the bots.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 71439b5..109a3d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,7 @@ option(AMBER_SKIP_SHADERC
"Skip building Shaderc into the library" ${AMBER_SKIP_SHADERC})
option(AMBER_SKIP_SAMPLES
"Skip building sample application" ${AMBER_SKIP_SAMPLES})
+option(AMBER_USE_LOCAL_VULKAN "Build with vulkan in third_party" OFF)
if (${AMBER_SKIP_SPIRV_TOOLS})
set(AMBER_ENABLE_SPIRV_TOOLS FALSE)
@@ -65,6 +66,12 @@ else()
set(AMBER_ENABLE_SAMPLES TRUE)
endif()
+if (${AMBER_USE_LOCAL_VULKAN})
+ message(STATUS "Using python3")
+ # vulkan-loaders requires python 3
+ find_package(PythonInterp 3 REQUIRED)
+endif()
+
message(STATUS "Amber enable SPIRV-Tools: ${AMBER_ENABLE_SPIRV_TOOLS}")
message(STATUS "Amber enable Shaderc: ${AMBER_ENABLE_SHADERC}")
message(STATUS "Amber enable tests: ${AMBER_ENABLE_TESTS}")