aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordan sinclair <dj2@everburning.com>2019-02-06 20:38:12 -0500
committerJaebaek Seo <duke.acacia@gmail.com>2019-02-06 20:38:12 -0500
commit2f596671b17199fac59f0bbf82f611e9903e7302 (patch)
tree005709e7277f271f77cd8cd9e652b236292629be /CMakeLists.txt
parent371f2aea208103171de5409a2f76d3afadab0e44 (diff)
downloadamber-2f596671b17199fac59f0bbf82f611e9903e7302.tar.gz
[amberscript] Parse PIPELINE BIND calls for color and depth buffers (#256)
This CL adds parsing for the AmberScript color and depth attachments. It also updates the pipelines to create a default color or depth attachment if one is not provided.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c66352e..71439b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,6 +110,7 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
-Wextra
-Wno-c++98-compat
-Wno-c++98-compat-pedantic
+ -Wno-format-pedantic
-Wno-padded
-Wno-switch-enum
-Wno-unknown-pragmas